OVH Community, votre nouvel espace communautaire.

Problème après mise à jour vers PHP5.5


freemaster
01/09/2015, 15h32
essayes :
chown nico: index.php
chmod 705 index.php

ceci dit je n'ai pas de R3

Nixtis
01/09/2015, 14h51
En fait du coup j'ai réinstallé suphp et ça a fonctionné merci Par contre maintenant j'ai une autre erreur. Quand j'essaye d'accéder à l'un de mes sites j'ai une erreur 500 et dans les log j'ai cette erreur :

GID of script 'chemin vers mon index.php' is smaller than min_gid ovh forum

J'ai essayé tous les chown possibles ça ne fonctionne toujours pas...

Voilà mon suphp.conf :

[global]
logfile=/var/log/httpd/suphp_log
loglevel=info
webserver_user=apache
docroot=/
env_path=/bin:/usr/bin
umask=0077
min_uid=500
min_gid=500

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

[handlers]
;Handler for php-scripts
x-httpd-php=php:/usr/bin/php

;Handler for CGI-scripts
x-suphp-cgi=execute:!self

voilà les détails de mon index.php :

-rw----r-- 1 nico users 2210 1 sept. 14:50 index.php

sachant que "nico" est le user du ftp (est-ce bien cet user qu'il faut mettre ?). J'ai essayé de le changer en root et en apache ça ne change strictement rien. J'ai essayé aussi de désactiver SELinux mais toujours le même soucis de GID. Avez-vous déjà eu ce genre de soucis ?

Merci !

freemaster
01/09/2015, 12h39
# touch /etc/httpd/conf.d/suphp.conf

et démarres apache

Nixtis
01/09/2015, 12h24
Bonjour à tous,

Je viens d'acquérir un serveur dédié chez Soyoustart. Je suis encore en phase de configuration, j'ai vu qu'avec la Release 3 il n'y avait que php5.3 d'installé, or avec ma version de Zend il me faut une version plus récente. Du coup j'ai suivi un tutoriel afin d'intaller PHP5.5 seulement maintenant Apache ne veut plus démarrer. Voici le message d'erreur que j'ai :

Code:
Démarrage de httpd*: httpd: Syntax error on line 857 of /etc/httpd/conf/httpd.conf: Could not open configuration file /etc/httpd/conf.d/suphp.conf: No such file or directory
Quand je tape php -v j'ai bien la dernière version de PHP

Code:
rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
yum install php55w php55w-opcache
yum install yum-plugin-replace
yum replace php-common --replace-with=php55w-common
Voilà j'ai cherché sur google et essayé quelques aides mais rien de fonctionne..

Merci