OVH Community, votre nouvel espace communautaire.

Port 80


dorcia666
13/10/2015, 10h56
Citation Envoyé par captainadmin
Hello,

Pour revenir sur ce problème finalement résolu :

Le mot de passe root a été réinitialisé et l'accès renforcer avec une clé ssh.
C'est assez simple à faire en mode rescue avec un chroot sur le point de montage
mount /dev/md2 /mnt
chroot /mnt
passwd
vi /root/.ssh/authorized_keys

Une fois cette opération effectuée, le retour en mode normal ce fait simplement et l'accès ssh est fonctionnel.

Il restait à identifier le problème du service web.
Sans trop détailler, lorsqu'on fait des upgrade de plesk, il arrive que certains services soient désactivés car ils sont en doublons comme nginx lorsque apache est la.
Donc on était dans ce cas.
Il a fallu réactiver nginx et le redémarrer.
/usr/local/psa/admin/sbin/nginxmng -e
service nginx start

Bon courage aux autres.
Je ne connais pas la criticité des sites mais pour information
10 jours de forum vs 2h de sysadmin pour résoudre le problème

http://www.captainadmin.com
Bravo pour la résolution... rapide !

captainadmin
13/10/2015, 09h41
Hello,

Pour revenir sur ce problème finalement résolu :

Le mot de passe root a été réinitialisé et l'accès renforcer avec une clé ssh.
C'est assez simple à faire en mode rescue avec un chroot sur le point de montage
mount /dev/md2 /mnt
chroot /mnt
passwd
vi /root/.ssh/authorized_keys

Une fois cette opération effectuée, le retour en mode normal ce fait simplement et l'accès ssh est fonctionnel.

Il restait à identifier le problème du service web.
Sans trop détailler, lorsqu'on fait des upgrade de plesk, il arrive que certains services soient désactivés car ils sont en doublons comme nginx lorsque apache est la.
Donc on était dans ce cas.
Il a fallu réactiver nginx et le redémarrer.
/usr/local/psa/admin/sbin/nginxmng -e
service nginx start

Bon courage aux autres.
Je ne connais pas la criticité des sites mais pour information
10 jours de forum vs 2h de sysadmin pour résoudre le problème

http://www.captainadmin.com

dorcia666
09/10/2015, 13h17
en tapant parted j'obtient :
Code:
root@rescue:~# parted -l
Model: ATA HGST HUS724020AL (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name     Flags
 1      20.5kB  1049kB  1029kB                  primary  bios_grub
 2      2097kB  126GB   126GB   ext4            primary  raid
 3      126GB   1998GB  1872GB  ext4            primary  raid
 4      1998GB  2000GB  2146MB  linux-swap(v1)  primary


Model: ATA HGST HUS724020AL (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name     Flags
 1      20.5kB  1049kB  1029kB                  primary  bios_grub
 2      2097kB  126GB   126GB   ext4            primary  raid
 3      126GB   1998GB  1872GB  ext4            primary  raid
 4      1998GB  2000GB  2146MB  linux-swap(v1)  primary


Model: Linux Software RAID Array (md)
Disk /dev/md2: 126GB
Sector size (logical/physical): 512B/512B
Partition Table: loop
Disk Flags: 

Number  Start  End    Size   File system  Flags
 1      0.00B  126GB  126GB  ext4


Model: Linux Software RAID Array (md)
Disk /dev/md3: 1872GB
Sector size (logical/physical): 512B/512B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system  Flags
 1      0.00B  1872GB  1872GB  ext4
est-ce que mes commandes sont bonnes pour monter :
mount /dev/md2 /mnt/
mount /dev/md3 /mnt/home
ls -alh /mnt

là je change le mot de passe
chroot /mnt/
passwd root
que je saisis 2 fois
exit pour quitter le mode chroot
umount /dev/md3 /mnt/home
umount /dev/md2 /mnt/

dans le manager SYS Netboot à partir du disque dur
Puis,
en ssh : reboot

Est-ce cela ?

d'avance merci !

dorcia666
09/10/2015, 09h18
Citation Envoyé par Nowwhat
Yep, je sais, le tuto n'indique pas ce pas, pour autant important.
On y dit simplement:

Dans le Manager, enlève le boot sur Rescue, pour le placer dans Netboot ou "à partir de votre disque dur".
Puis exécute la commande (il faut saisir):
reboot
dans la session SSH. Votre serveur redémarrera normalement d'une façon propre, contrôlé.

Le reboot forcé dans le Manager est en réalité un petit coupure d'alimentation de votre serveur. Un hard reset.
C'est bon pour casser le file system, le raid - tout simplement : vos données.
merci de l'info...
hier après avoir effectué tout cela ( indiqué dans message 18h00 ) pas d'accès en mode normal en ssh. SYS me demande un traceroute et voit que d'où je suis le serveur est inaccessible alors que de leur côté ils y ont accès.
rebelote ce matin / retour en mode rescue.
Code:
Linux rescue.ovh.net 3.14.32-xxxx-std-ipv6-64-rescue #5 SMP Tue Sep 8 18:09:46 CEST 2015 x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
root@rescue:~# mount /dev/md2 /mnt/
root@rescue:~# mount /dev/md3 /mnt/home
root@rescue:~# ls -alh /mnt
total 544K
dr-xr-xr-x 25 root root 4.0K Oct  8 15:12 .
drwxrwxrwt 19 root root  460 Oct  9 10:41 ..
-rw-r--r--  1 root root    0 Oct  8 15:12 .autofsck
-rw-r--r--  1 root root    0 May  6  2014 .autorelabel
drwxr-xr-x  2 root root 4.0K May 21  2014 .lftp
drwxr-----  3 root root 4.0K May  6  2014 .pki
drwx------  2 root root 4.0K May  6  2014 .spamassassin
dr-xr-xr-x  2 root root 4.0K Aug  7 11:49 bin
dr-xr-xr-x  4 root root 4.0K May  6  2014 boot
drwxr-xr-x  2 root root 4.0K Jul  8  2011 dev
drwxr-xr-x 90 root root 4.0K Oct  9 03:33 etc
drwxr-xr-x 27 root root 4.0K Aug 12  2014 home
dr-xr-xr-x 12 root root 4.0K Aug  7 11:49 lib
dr-xr-xr-x 10 root root  12K Aug 20 08:51 lib64
drwx------  2 root root  16K May  6  2014 lost+found
drwxr-xr-x  2 root root 4.0K Sep 23  2011 media
drwxr-xr-x  2 root root 4.0K Sep 23  2011 mnt
drwxr-xr-x  3 root root 4.0K Aug 12  2013 opt
drwxr-xr-x  2 root root 4.0K May  6  2014 proc
dr-xr-x---  7 root root 4.0K Jan  8  2015 root
dr-xr-xr-x  2 root root  12K Aug 20 08:51 sbin
drwxr-xr-x  2 root root 4.0K Sep 23  2011 selinux
drwxr-xr-x  2 root root 4.0K Sep 23  2011 srv
drwxr-xr-x  2 root root 4.0K Jul  8  2011 sys
drwxrwxrwt  3 root root 420K Oct  9 03:33 tmp
drwxr-xr-x 13 root root 4.0K Dec 20  2011 usr
drwxr-xr-x  2 root root 4.0K May  6  2014 var
root@rescue:~# chroot /mnt/
[root@rescue /]# passwd root
Changement de mot de passe pour l'utilisateur root.
Nouveau mot de passe : 
Retapez le nouveau mot de passe : 
passwd : mise à jour réussie de tous les jetons d'authentification.
[root@rescue /]#
là je vais

exit pour quitter le mode chroot
umount /dev/md3 /mnt/home
umount /dev/md2 /mnt/
(dans l'ordre inverse du montage)
dans le manager SYS Netboot à partir du disque dur
Puis,
en ssh : reboot

ma question est comment être sûr que je monte les bonnes partitions ?
md correspond à du raid.


merci de l'aide !

Nowwhat
08/10/2015, 22h54
Citation Envoyé par dorcia666
.....
par contre j'ai pas exit le chroot ni unmount...
reboot par manager SYS...
Yep, je sais, le tuto n'indique pas ce pas, pour autant important.
On y dit simplement:
ah oui, et pour ressortir du rescue me direz-vous ?
Très simple, manager, netboot (sur HD ou netboot) puis reboot du serveur, si vous ne faites pas cela, vous rebooterez en rescue, oui je sais c'est bête mais des fois les choses les plus évidentes peuvent nous échapper
Dans le Manager, enlève le boot sur Rescue, pour le placer dans Netboot ou "à partir de votre disque dur".
Puis exécute la commande (il faut saisir):
reboot
dans la session SSH. Votre serveur redémarrera normalement d'une façon propre, contrôlé.

Le reboot forcé dans le Manager est en réalité un petit coupure d'alimentation de votre serveur. Un hard reset.
C'est bon pour casser le file system, le raid - tout simplement : vos données.

dorcia666
08/10/2015, 16h00
merci de la réponse...
j'avais bien suivi les instructions du lien Kimsufi.
par contre j'ai pas exit le chroot ni unmount...
reboot par manager SYS...

la suite au prochain épisode !

Nowwhat
08/10/2015, 15h35
Citation Envoyé par dorcia666
....
Dois-je faire une autre commande avant de rebooter le serveur sur HD à partir de la console SYS ?
Pour faire propre:
"exit" ton chroot.
umount (un-mount) ce que t'as mounté.

Dans le manager, place ton serveur type e Boot: Netboot ou "à partir de ton disque dur".
Puis, dans la session SSH tu tape
reboot

Un redémarrage dans le manager de ton serveur SYS : jamais - sauf cas d'urgence extrême.

Confirme quand même que t'as bien suivi tous ce qui a été dit ici https://forum.kimsufi.com/showthread...TO-Mode-rescue

Après le reboot, ton serveur accepte ton mot de passe (sous réserve que le serveur a bien démarré - qu'il a exécuté éventuellement son 'fsck', la service sshd tourne, etc)

dorcia666
08/10/2015, 13h06
Citation Envoyé par Nowwhat
T'as donc inclus des liens .... (vers l'image). Faut pas. Un copie collé de l'écran est bien plus simple. PENSE (== pas oublier) de mettre les [CODE] ... [/CODE].


Aha !! Tu t'echape plus. Va vouloir que tu te tape le minum indispensable : https://forum.kimsufi.com/forumdisplay.php?18-How-To-Tutoriels - tu trouveras entre autre comment "mounter" tes partitions.


Quand ton serveur bascule en mode rescue, t'as du recevoir un mail.
Dans ce mail, il y a des instructions.
En gros, c'est toujours l’utilisateur nommé 'root', mais t'auras un mot de passe' temporaire, uniquement valable pour cette session de 'rescue'.

Bien attendu, il te faut 'Putty' (si t'as un Windows).

Sinon, t'inquiète, t'es dans l'avion que t'as commandé - il vole, c'est partie. Il est donc temps que tu apprenne à voler .... on est tous passé par la, ça le fait bien sur un KS qui est, après tout, un serveur d’apprentissage.
Merci !
J'ai réussi à me connecter. monter les partitions
j'ai modifié le mdp.
Dois-je faire une autre commande avant de rebooter le serveur sur HD à partir de la console SYS ?

dorcia666
08/10/2015, 12h39
j'ai alors essayé d'installer GParted

Code:
sudo apt-get install gparted
W: Not using locking for read only lock file /var/lib/dpkg/lock
E: Unable to write to /var/cache/apt/
E: The package lists or status file could not be parsed or opened.
root@rescue:~# Write failed: Broken pipe

dorcia666
08/10/2015, 12h38
merci de ta réponse.
je suis à l'étape suivante...
j'utilise terminal pour me connecter en ssh (j'ai un mac devant moi)
j'ai tapé mon mon de passe
et en tapant fdisk -l
j'obtient :
Code:
WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  3907029167  1953514583+  ee  GPT

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1  3907029167  1953514583+  ee  GPT

Disk /dev/md3: 1872.4 GB, 1872417980416 bytes
2 heads, 4 sectors/track, 457133296 cylinders, total 3657066368 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/md3 doesn't contain a valid partition table

Disk /dev/md2: 125.8 GB, 125828005888 bytes
2 heads, 4 sectors/track, 30719728 cylinders, total 245757824 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/md2 doesn't contain a valid partition table

Nowwhat
08/10/2015, 10h12
Citation Envoyé par dorcia666
j'ai essayé de joindre 2 petites images concernant mon problème, et ai inclus un log de mon activité en utilisant ssh pour comprendre mes erreurs et autres...
T'as donc inclus des liens .... (vers l'image). Faut pas. Un copie collé de l'écran est bien plus simple. PENSE (== pas oublier) de mettre les [CODE] ... [/CODE].

Citation Envoyé par dorcia666
je suis en mode rescue, comment monter le disque ?
Aha !! Tu t'echape plus. Va vouloir que tu te tape le minum indispensable : https://forum.kimsufi.com/forumdisplay.php?18-How-To-Tutoriels - tu trouveras entre autre comment "mounter" tes partitions.

Citation Envoyé par dorcia666
je dois l'identifier d'abord ? comment faire ? (oui je ne connais pas les bases linux..)
Quand ton serveur bascule en mode rescue, t'as du recevoir un mail.
Dans ce mail, il y a des instructions.
En gros, c'est toujours l’utilisateur nommé 'root', mais t'auras un mot de passe' temporaire, uniquement valable pour cette session de 'rescue'.

Bien attendu, il te faut 'Putty' (si t'as un Windows).

Sinon, t'inquiète, t'es dans l'avion que t'as commandé - il vole, c'est partie. Il est donc temps que tu apprenne à voler .... on est tous passé par la, ça le fait bien sur un KS qui est, après tout, un serveur d’apprentissage.

dorcia666
08/10/2015, 08h33
est-ce normal que les partitions soient en GPT ?

dorcia666
08/10/2015, 08h32
en tapant fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sda1 1 3907029167 1953514583+ ee GPT

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdb1 1 3907029167 1953514583+ ee GPT

Disk /dev/md3: 1872.4 GB, 1872417980416 bytes
2 heads, 4 sectors/track, 457133296 cylinders, total 3657066368 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/md3 doesn't contain a valid partition table

Disk /dev/md2: 125.8 GB, 125828005888 bytes
2 heads, 4 sectors/track, 30719728 cylinders, total 245757824 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/md2 doesn't contain a valid partition table

dorcia666
08/10/2015, 07h52
mon premier soucis est très basique...
je suis en mode rescue, comment monter le disque ?
je dois l'identifier d'abord ? comment faire ? (oui je ne connais pas les bases linux..)

dorcia666
08/10/2015, 07h44
j'ai essayé de joindre 2 petites images concernant mon problème, et ai inclus un log de mon activité en utilisant ssh pour comprendre mes erreurs et autres...

dorcia666
08/10/2015, 07h42
Citation Envoyé par Nowwhat
Pour s’inscrire deux fois ?

Évite simplement d'utiliser des liens (URL's) ou 'casse' les avant de poster.
Genre
oui ! dans mes messages non envoyés, rien de ce type !

Nowwhat
08/10/2015, 06h29
Citation Envoyé par dorcia
j'envoie des messages... mais il semble y avoir un problème...
"Merci pour votre message ! Votre message ne sera pas visible jusqu'à ce qu'un modérateur l'approuve."
Citation Envoyé par dorcia666
oui j'ai besoin d'aide...
Pour s’inscrire deux fois ?

Évite simplement d'utiliser des liens (URL's) ou 'casse' les avant de poster.
Genre
http www dot google dot fr
au lieu de
http://www.google.fr

sloomy
08/10/2015, 05h57
Bonjour,

Tu peux nous faire un résumé de la situation ?

Bruno

dorcia
07/10/2015, 22h48
la situation est la suivante, je suis de nouveau en mode rescue et j'essaie de monter le HD
Pièce jointe 68
Pièce jointe 69

extrait du log

root@rescue:/dev# mount /dev/sda1 /mnt
mount: block device /dev/sda1 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# umount/mnt
-bash: umount/mnt: No such file or directory
root@rescue:/dev# mount /dev/sda2 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda3 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda4 /mnt
/dev/sda4 looks like swapspace - not mounted
mount: you must specify the filesystem type
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# logout

dorcia666
07/10/2015, 22h47
la situation est la suivante, je suis de nouveau en mode rescue et j'essaie de monter le HD
Pièce jointe 68
Pièce jointe 69

extrait du log

root@rescue:/dev# mount /dev/sda1 /mnt
mount: block device /dev/sda1 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# umount/mnt
-bash: umount/mnt: No such file or directory
root@rescue:/dev# mount /dev/sda2 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda3 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda4 /mnt
/dev/sda4 looks like swapspace - not mounted
mount: you must specify the filesystem type
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# logout

dorcia666
07/10/2015, 22h39
oui j'ai besoin d'aide...

dorcia
07/10/2015, 22h37
j'envoie des messages... mais il semble y avoir un problème...

"Merci pour votre message ! Votre message ne sera pas visible jusqu'à ce qu'un modérateur l'approuve."

dorcia666
07/10/2015, 22h36
Pièce jointe 66Pièce jointe 67
bonjour,

aujourd'hui le serveur a été remis en mode rescue.

et je m'interroge sur la taille des partitions et le système de fichiers. Est ce que tout selon semble normal ?
les images jointes sont tirées de l'interface de http de SYS.

D'autre part en essayant de monter, voila le log :


root@rescue:/dev# mount /dev/sda1 /mnt
mount: block device /dev/sda1 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# umount/mnt
-bash: umount/mnt: No such file or directory
root@rescue:/dev# mount /dev/sda2 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda3 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda4 /mnt
/dev/sda4 looks like swapspace - not mounted
mount: you must specify the filesystem type
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy

merci de vos analyses et aide !

sloomy
07/10/2015, 15h35
Bonjour,

Bon courage, tiens nous au courant.
Si tu as besoin d'aide

Cordialement,
Bruno

dorcia666
07/10/2015, 14h44
Citation Envoyé par captainadmin
Hello,

Replace toi en mode rescue
De la il faut que tu te place sur ton système pour changer le mot de passe ssh.

Tu commences par monter ton disque, il doit y avoir des sda1 ou 2 ou 3 ou 4 dans /dev
mount /dev/sda1 /mnt
ls /mnt

Dans /mnt tu dois voir l'arborescence de ton serveur sinon umount /mnt et tu recommences avec le sda suivant

Quand ton disque est monté, tu prends le controle
chroot /mnt
Une console s'ouvre (ou le prompt change) et tu vas pouvoir changer le mot de passe.
passwd ## ensuite il te demande 2 fosi le nouveau mot de passe.

Une fois que tu as réinitialisé le mot de passe, tu peux reboot en mode normal et te connecter normalement

Reste à voir si tes services sont lancés et si ton système est ok

Bon courage
http://www.captainadmin.com
Pièce jointe 66Pièce jointe 67
bonjour,

aujourd'hui le serveur a été remis en mode rescue.

et je m'interroge sur la taille des partitions et le système de fichiers. Est ce que tout selon semble normal ?
les images jointes sont tirées de l'interface de http de SYS.

D'autre part en essayant de monter, voila le log :


root@rescue:/dev# mount /dev/sda1 /mnt
mount: block device /dev/sda1 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# umount/mnt
-bash: umount/mnt: No such file or directory
root@rescue:/dev# mount /dev/sda2 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda3 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda4 /mnt
/dev/sda4 looks like swapspace - not mounted
mount: you must specify the filesystem type
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy

merci de vos analyses et aide !

dorcia666
07/10/2015, 14h05
Pièce jointe 66Pièce jointe 67
bonjour,

aujourd'hui le serveur a été remis en mode rescue.

et je m'interroge sur la taille des partitions et le système de fichiers. Est ce que tout selon semble normal ?
les images jointes sont tirées de l'interface de http de SYS.

D'autre part en essayant de monter, voila le log :


root@rescue:/dev# mount /dev/sda1 /mnt
mount: block device /dev/sda1 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# umount/mnt
-bash: umount/mnt: No such file or directory
root@rescue:/dev# mount /dev/sda2 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda3 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda4 /mnt
/dev/sda4 looks like swapspace - not mounted
mount: you must specify the filesystem type
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy

merci de vos analyses et aide !

dorcia666
07/10/2015, 14h03
Pièce jointe 66Pièce jointe 67
bonjour,

aujourd'hui le serveur a été remis en mode rescue.

et je m'interroge sur la taille des partitions et le système de fichiers. Est ce que tout selon semble normal ?
les images jointes sont tirées de l'interface de http de SYS.

D'autre part en essayant de monter, voila le log :


root@rescue:/dev# mount /dev/sda1 /mnt
mount: block device /dev/sda1 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/sda1': Invalid argument
The device '/dev/sda1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy
root@rescue:/dev# umount/mnt
-bash: umount/mnt: No such file or directory
root@rescue:/dev# mount /dev/sda2 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda3 /mnt
mount: unknown filesystem type 'linux_raid_member'
root@rescue:/dev# mount /dev/sda4 /mnt
/dev/sda4 looks like swapspace - not mounted
mount: you must specify the filesystem type
root@rescue:/dev# mount /dev/sda /mnt
mount: /dev/sda already mounted or /mnt busy

merci de vos analyses et aide !

dorcia666
06/10/2015, 10h41
j'y retourne.... à la prochaine...

dorcia666
06/10/2015, 10h38
merci !
le disque n'avait pas été monté...

captainadmin
06/10/2015, 10h10
Hello,

Replace toi en mode rescue
De la il faut que tu te place sur ton système pour changer le mot de passe ssh.

Tu commences par monter ton disque, il doit y avoir des sda1 ou 2 ou 3 ou 4 dans /dev
mount /dev/sda1 /mnt
ls /mnt

Dans /mnt tu dois voir l'arborescence de ton serveur sinon umount /mnt et tu recommences avec le sda suivant

Quand ton disque est monté, tu prends le controle
chroot /mnt
Une console s'ouvre (ou le prompt change) et tu vas pouvoir changer le mot de passe.
passwd ## ensuite il te demande 2 fosi le nouveau mot de passe.

Une fois que tu as réinitialisé le mot de passe, tu peux reboot en mode normal et te connecter normalement

Reste à voir si tes services sont lancés et si ton système est ok

Bon courage
http://www.captainadmin.com

dorcia666
06/10/2015, 08h59
j'ai rebooté (net reboot) et demarrage à partir du disque dur puis tapé en ssh reboot.

résultat :en ssh mdp refusé (Permission denied, please try again.)
site toujours non accessible bien évidemment.

et depuis peu...

"Operation timed out"

je suis retourné au départ du problème...

dorcia666
06/10/2015, 08h32
Citation Envoyé par Nowwhat
Le mode rescue t'as filé un mail avec le mot de passe 'root' pour entrer avec SSH ?
Si oui, n'utilise PAS l'option 'redémarrage' dans le Manager de SYS, ça revient à effectuer un cold reboot, fortement dé"conseillé.

Bascule ton serveur en NetBoot ou 'démarrage à partir de ton disque dur', puis tpae ce commande dans la session SSH:
reboot

C'est beaucoup plus propre.

Tu tire pas non plus la prise électrique de ton ordi pour le faire redémarrer, un jour tu va regretter ...
merci du soutien !

1. oui login reçu pour accès SSH
2. j'ai changé son mdp
je viens de rebooter, et plus d'accès en ssh ( après saisie ligne ssh root@x.x.x.x -p 22 demande de mot de passe et "Permission denied, please try again."

que faire ?

dorcia666
06/10/2015, 08h13
merci de vos interventions...
@Nowwhat : oui j'ai eu les infos de connexion de SYS.
je redémarre comme indiqué !

bbr
06/10/2015, 07h56
perso je conseille le démarrage sur le netboot réseau car on est sur d'avoir toujours le noyau à jour

Nowwhat
06/10/2015, 07h48
Le mode rescue t'as filé un mail avec le mot de passe 'root' pour entrer avec SSH ?
Si oui, n'utilise PAS l'option 'redémarrage' dans le Manager de SYS, ça revient à effectuer un cold reboot, fortement dé"conseillé.

Bascule ton serveur en NetBoot ou 'démarrage à partir de ton disque dur', puis tpae ce commande dans la session SSH:
reboot

C'est beaucoup plus propre.

Tu tire pas non plus la prise électrique de ton ordi pour le faire redémarrer, un jour tu va regretter ...

bbr
06/10/2015, 07h38
avant d'appuyer sur redémarrer, tu vas sur Netboot, tu choisis Réseau puis stable kernel vanilla 64 bits, ensuite tu redémarres le serveur

dorcia666
06/10/2015, 07h26
Citation Envoyé par Nowwhat
Une possibilité : un non-spécialiste-de-parafeu a appliqué sur son serveur des règles qui ont bloqué le RTM et 'ping-check'.
Avec les conséquences qui font avec

@dorcia666 dès que ton serveur est en ligne, vérifie que ton parafeu ressemble à:
merci de l'info, je vérifie cela dès qu'il est en ligne.

dorcia666
06/10/2015, 07h24
Citation Envoyé par sloomy
Bonjour,

Il faut changer le boot système dans l'interface SYS.

Cordialement,
Bruno

PS : je me poserais qu'en même la question du pourquoi et comment mon serveur est passé en mode : rescue.

le serveur a été passé en mode rescue à notre demande ( plus d'accès au site qu'il héberge - suite à un (13/09/2015 08:22 SOFT Reboot), réponse OVH/SYS port 80 inaccessible, absence de notre côté des codes d'accès pour accès ssh, reboot en mode rescue de SYS pour obtenir code d'accès et mdp, verification du hardware)

j'appuie sur redémarrer dans l'interface SYS ?

merci d'avance !

Nowwhat
05/10/2015, 06h52
Citation Envoyé par sloomy
B.....
PS : je me poserais qu'en même la question du pourquoi et comment mon serveur est passé en mode : rescue.
Une possibilité : un non-spécialiste-de-parafeu a appliqué sur son serveur des règles qui ont bloqué le RTM et 'ping-check'.
Avec les conséquences qui font avec

@dorcia666 dès que ton serveur est en ligne, vérifie que ton parafeu ressemble à:
iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

sloomy
04/10/2015, 15h50
Bonjour,

Il faut changer le boot système dans l'interface SYS.

Cordialement,
Bruno

PS : je me poserais qu'en même la question du pourquoi et comment mon serveur est passé en mode : rescue.

dorcia666
04/10/2015, 15h08
Citation Envoyé par Nowwhat
Donc la reste de votre résumé n'a plus d'importance.
IL faut d'abord savoir ce que c'est, ce mode "rescue".
Et à partir de la refaire vos questions.

La porte "80", il n'est pas cassé, il n'est pas bloqué une - sauf si vous ajoutez des règles parafeu (pour info: ne le fait jamais avant d'étudier ce que c'est un parafeu), soit vous avez arrêté votre serveur web, comme arrêter "apache2", soit, suit à un mauvaise paramétrage, le serveur web (entre autre) est arrêté, soit, et pourquoi pas: (exemple) votre disque dur est en panne, donc le serveur web marche plus, donc vous avez pensez qu'il y a un soucis avec la porte "80" car .....votre disque dur est cassé ... (ce qui explique pourquoi SYS a mis votre serveur en mode rescue).

D'ailleurs, ça tombe bien, le mode rescue offre la possibilité de tester votre matériel (serveur) - disque dur, RAM, etc.
Merci de votre réponse.
Oui, le mode rescue a permis de vérifier que le hardware semble OK.
je dosi repasser en mode normal. (comment?)
et vérifier si le port 80 est accessible.

dorcia666
04/10/2015, 15h06
Citation Envoyé par captainadmin
Bonjour,

Difficile de faire du SOI avec toi sans savoir ce qui se passe sur ton serveur.

Le mieux en mode rescue tu redéfinis le mot de passe de ton serveur et tu le relances pour te connecter dessus.
il faut vérifier que le service web fonction et le relancer si besoin,
netstat -laputen |grep 80
ca te permettra de voir si un service fonctionne sur le port 80, tu peux faire pareil avec 443

Sinon pour le reste demande un devis d'intervention.

Bonne journée
http://www.captainadmin.com
Merci de ton aide.
Je pense que le problème est tout con.

Ok pour redéfinir un mdp : passwd
puis le relancer : restart

Ne dois-je pas remonter le HD ?

N'oublie pas que les serveurs et le ssh n'est pas mon truc, mais que j'apprends vite (en général)

Nowwhat
03/10/2015, 14h24
Citation Envoyé par dorcia666
...
le serveur est en mode rescue.
Donc la reste de votre résumé n'a plus d'importance.
IL faut d'abord savoir ce que c'est, ce mode "rescue".
Et à partir de la refaire vos questions.

La porte "80", il n'est pas cassé, il n'est pas bloqué une - sauf si vous ajoutez des règles parafeu (pour info: ne le fait jamais avant d'étudier ce que c'est un parafeu), soit vous avez arrêté votre serveur web, comme arrêter "apache2", soit, suit à un mauvaise paramétrage, le serveur web (entre autre) est arrêté, soit, et pourquoi pas: (exemple) votre disque dur est en panne, donc le serveur web marche plus, donc vous avez pensez qu'il y a un soucis avec la porte "80" car .....votre disque dur est cassé ... (ce qui explique pourquoi SYS a mis votre serveur en mode rescue).

D'ailleurs, ça tombe bien, le mode rescue offre la possibilité de tester votre matériel (serveur) - disque dur, RAM, etc.

captainadmin
03/10/2015, 12h51
Bonjour,

Difficile de faire du SOI avec toi sans savoir ce qui se passe sur ton serveur.

Le mieux en mode rescue tu redéfinis le mot de passe de ton serveur et tu le relances pour te connecter dessus.
il faut vérifier que le service web fonction et le relancer si besoin,
netstat -laputen |grep 80
ca te permettra de voir si un service fonctionne sur le port 80, tu peux faire pareil avec 443

Sinon pour le reste demande un devis d'intervention.

Bonne journée
http://www.captainadmin.com

dorcia666
03/10/2015, 11h02
Merci de votre réponse. D'après SYS c'est le cas...
Linux rescue.ovh.net 3.14.32-xxxx-std-ipv6-64-rescue #5 SMP Tue Sep 8 18:09:46 CEST 2015 x86_64
le serveur est en mode rescue.

résumé :
site non accessible
back office non accessible
SYS informe d'un reboot (à l'origine du problème)
et donc informe que le port 80 est inaccessible.
ne pouvant intervenir en ssh (problème de mot de passe)
SYS indique la nécessité de passer en mode rescue pour nous envoyer le login et code.
accès en ssh mode rescue
iptables après intervention (j'ai rajouté les deux règles port 80 et 443) :

iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT tcp -- anywhere anywhere tcp dpt:http
ACCEPT tcp -- anywhere anywhere tcp dpt:https

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

pouvez vous m'orienter vers la prochaine procédure ( monter HD et reboot ?)


D'avance merci !

sloomy
02/10/2015, 14h21
Bonjour,

Il faut regarder si le firewall de votre système est pas activé et bloquerait le port 80
Des informations sur votre distribution nous aiderait.

Cordialement,
Bruno

dorcia666
02/10/2015, 13h48
Citation Envoyé par bubblecom
Désolé pour le retour tardif, votre site est désormais dans mes favoris ;-) bonne soirée Capt'ain
Bonjour !

Je rencontre un problème identique, Pouvez-vous expliquer comment vous l'avez solutionné de votre côté.

Merci d'avance !

bubblecom
25/09/2015, 21h35
Désolé pour le retour tardif, votre site est désormais dans mes favoris ;-) bonne soirée Capt'ain

captainadmin
25/09/2015, 21h12
Je suis déception ...

Bon courage sur codeur.com

captainadmin
25/09/2015, 20h47
Bonjour,

Il faut aller voir ce qu'il se passe sur le serveur, soit via l'interface ISPconfig si tu as le service web de lancé ou simplement si le port est ouvert.
Si tu as l'accès ssh au serveur, tu pourras effectuer plus d'action comme relancer les services et regarder les logs.
Privilégie la connexion ssh et regarde si ton service web est lancé .

Es-tu sur que le port est fermé ou qu'il n'y a pas de serveur web qui écoute?

Si c'est le port, il faut l'ouvrir via une commande du type
iptables -t filter -A INPUT -p tcp --dport 80 -j ACCEPT

Bon courage
http://www.captainadmin.com

bubblecom
25/09/2015, 20h21
Bonjour à tous.

Totalement nul en admin serveur, et ayant mon informaticien en voyage en inde... Je me tourne vers vous.
Nous disposons d'un soyoustart ISPconfig 3.0.5.4 (Debian 7) (64bits)
Ce dernier ce trouve à première vue avec le port 80 entre autre fermé, ce qui est très génant. Que puis je faire pour le ré ouvrir?
Merci par avance.