OVH Community, votre nouvel espace communautaire.

Debian+Apache+failover


Lolothomas
15/10/2015, 07h42
bonjour

monservice.toto.com IN A 178.xx.xxx.xxx
se fait avec Bind ?

Sinon
dig @sdns2.ovh.net -t a www.domaine.fr
est ok par contre
dig @12.34.56.78 -t a www.domaine.fr
conduit à une erreur ?

merci
lolo

Lolothomas
14/10/2015, 12h15
Bonjour

en fait je créée cela où, sous bind ?

merci

remarque : quand je
dig @12.34.56.78 -t a www.domaine.fr
error
et
dig @sdns2.ovh.net -t a www.domaine.fr
tout est ok


Citation Envoyé par captainadmin
Hello,

Je te conseil de créer ton reverse.
Tu commences par faire un pointage DNS vers l'ip qui te concerne comme pour nommer le service.

monservice.toto.com IN A 178.xx.xxx.xxx
http://www.captainadmin.com

captainadmin
13/10/2015, 10h46
Hello,

Je te conseil de créer ton reverse.
Tu commences par faire un pointage DNS vers l'ip qui te concerne comme pour nommer le service.

monservice.toto.com IN A 178.xx.xxx.xxx


Tu attends la propagation DNS de quelques heures (si tu reviens le lendemain tu es sur que c'est ok)
Et tu pourras mettre le reverse avec le nom que tu viens de de choisir pour ton service.

C'est plus propre et surtout plus lisible.

Sinon 178.xx.xxx.xxx.ovh.net n'existe pas chez ovh, tu dois plutot avoir la syntaxe 178-xx-xxx-xxx.ovh.net

Bon journée
http://www.captainadmin.com

Lolothomas
11/10/2015, 08h21
Ok donc quand j'essaie de rentrer IP-IP FAIL OVER - REVERSE

donc 178.xx.xxx.xxx.ovh.net j'ai le message

"Cannot check if 178.xx.xxx.xxx.ovh.net resolves to 178.xx.xxx.xxx"
est-ce un problème de syntaxe ?

lolo

bbr
11/10/2015, 07h01
IP-IP FAIL OVER - REVERSE
l'autre ( AJOUTER UN DNS SECONDAIRE-DOMAINE A AJOUTER ) c'est pour ajouter tes domaines aux DNS secondaires d'OVH

Lolothomas
10/10/2015, 20h27
Pour le reverse dns à déclarer dans le manager de soyoustart, (si j'ai bien compris)
Faut-il dans le manager aller dans
IP-IP FAIL OVER - REVERSE
ou
DNS-AJOUTER UN DNS SECONDAIRE-DOMAINE A AJOUTER-IP BLOCK-IP

merci

lolo

Lolothomas
09/10/2015, 20h45
bonjour
je n'arrive pas à créer le reverse sur soyoustart
je suis allé sur ip-ipfo-reverse et la je rentre ipfo.ovh.net mais la ligne reste vide ??

voila le message d'erreur
"Cannot check if 178.xx.xxx.xxx.ovh.net resolves to 178.xx.xxx.xxx"

lolo

freemaster
07/10/2015, 13h35
en même temps gandi te propose un dns secondaire : ns6.gandi.net
car sdns2.ovh.net est assez lent à se mettre à jour je trouve

bbr
07/10/2015, 07h43
tu crées le reverse sur l'ip fo sous cette forme : 111-222-333-444.ovh.net
tu mets ce reverse sur gandi en primaire et en secondaire : sdns2.ovh.net

Lolothomas
07/10/2015, 06h38
bonjour
je n'ai pas compris
1) je laisse donc vide dans la zone du manager de gandi DNS PRIMAIRE et SECONDAIRE ?
2) dans le manager de SOYOUSTART je créée le reverse DNS sur l'ip de mon serveur ou IP FO ?

lolo

bbr
06/10/2015, 15h12
le reverse d'une ip fo est sous cette forme par exemple si l'ip est 111.222.333.444 tu mets 111-222-333-444.ovh.net (il faut déclarer ce reverse dans le manager)

Lolothomas
06/10/2015, 12h48
merci nowwhat
mes 3 domaines sont gérés par gandi , j'avais mis à l'époque sur l'interface de GANDI pour les DNS primaire et secondaire puisque j'avais un kimsufi DNS1: ksxxx.kimsufi.com DNS2 : ns.kimsufi.com. Maintenant que les domaines doivent pointer vers les IPFAILOVER je mets quoi ?

lolo

Nowwhat
06/10/2015, 07h51
Ah, si !

Le doc : http://guide.ovh.com/IpFailover

Debian Jessie 3 : IP4FO et 3 IPv6 :

Code:
root@ns311465:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 188.165.a.b
        netmask 255.255.255.0
        network 188.165.a.0
        broadcast 188.165.a.255
        gateway 188.165.a.254

        post-up /sbin/ifconfig eth0:0 IPFO-1 netmask 255.255.255.255 broadcast IPFO-1
        post-up /sbin/ifconfig eth0:1 IPFO-2 netmask 255.255.255.255 broadcast IPFO-2
        post-up /sbin/ifconfig eth0:2 IPFO-3 netmask 255.255.255.255 broadcast IPFO-3

        pre-down /sbin/ifconfig eth0:2 down
        pre-down /sbin/ifconfig eth0:1 down
        pre-down /sbin/ifconfig eth0:0 down

# http://docs.ovh.ca/fr/guides-network-ipv6.html
iface eth0 inet6 static
        address 2001:41D0:x:xx::1
        netmask 64
        post-up /sbin/ip -family inet6 route add 2001:41D0:2:92ff:ff:ff:ff:ff dev eth0
        post-up /sbin/ip -family inet6 route add default via 2001:41D0:2:92ff:ff:ff:ff:ff

        post-up /sbin/ifconfig eth0 inet6 add IPv6-1
        post-up /sbin/ifconfig eth0 inet6 add IPv6-2
        post-up /sbin/ifconfig eth0 inet6 add IPv6-3

        pre-down /sbin/ifconfig eth0 inet6 del IPv6-1
        pre-down /sbin/ifconfig eth0 inet6 del IPv6-2
        pre-down /sbin/ifconfig eth0 inet6 del IPv6-3

        pre-down /sbin/ip -family inet6 route del default via 2001:41D0:x:xxff:ff:ff:ff:ff
        pre-down /sbin/ip -family inet6 route del 2001:41D0:x:xxff:ff:ff:ff:ff dev eth0

Lolothomas
05/10/2015, 21h06
bonjour Nowhat

du coup on ne touche pas à /etc/network/interfaces ?

lolo

Nowwhat
05/10/2015, 08h08
/etc/apache/ports.conf:
Avec ce port.conf - apache n'écoute plus du tout sur le IP natif de ton serveur.
Ce qui est logique après tout, un domaine pointre vers UN IP(FO)

Voici un exemple avec 3 IPFO et autant de IPv6, tant qu'on y est.
La partie 'SSL' est présent aussi.

Code:
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

# Native server IP is not used !!

Listen 127.0.0.1:80
Listen IPFO-1:80
Listen IPFO-2:80
Listen IPFO-3:80

Listen [IPv6-1]:80
Listen [IPv6-2]:80
Listen [IPv6-3]:80


    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to 
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.

	Listen 127.0.0.1:443
	Listen IPFO-1:443
	Listen IPFO-2:443
	Listen IPFO-3:443
   
	[::1]:443
	Listen [IPv6-1]:443
	Listen [IPv6-2]:443
	Listen [IPv6-3]:443
	



    Listen 443
Un fichier vhost pour le premier IPFO-1 (et IPv6): domaine-1.tld
Idem ici, la partie IPv6 est présent, comme le paramétrage avec des certificats (dispo gratuitement chez StartSSL):
Code:

	ServerAdmin postmaster@domaine-1.tld
	ServerName www.domaine-1.tld
	DocumentRoot /var/www/domaine-1.tld/
	
	CustomLog ${APACHE_LOG_DIR}/domaine-1_tld-access.log combined
	ErrorLog ${APACHE_LOG_DIR}/domaine-1_tld-error.log
	LogLevel warn

	
		Options ExecCGI Indexes FollowSymLinks MultiViews
		AllowOverride All
		Order allow,deny
		Allow from All
	



        
        ServerAdmin postmaster@domaine-1.tld
        ServerName www.domaine-1.tld
        DocumentRoot /var/www/domaine-1.tld
        
        ## Header always set Strict-Transport-Security "max-age=63072000; includeSubdomains; preload"
		Header add Strict-Transport-Security: "max-age=15768000"

        LogLevel warn
        CustomLog ${APACHE_LOG_DIR}/ssl_domaine-1.tld-access.log combined
        ErrorLog ${APACHE_LOG_DIR}/ssl_domaine-1.tld-error.log
		
        
                Options ExecCGI Indexes FollowSymLinks MultiViews
                # 2.4 Require all granted
                AllowOverride all
                Order allow,deny
                allow from all
        

        SSLEngine on

        SSLCertificateFile    /root/startssl/domaine-1.tld/ssl.crt
        SSLCertificateKeyFile /root/startssl/domaine-1.tld/ssl-decrypted.key

        SSLCACertificateFile  /root/startssl/ca.pem

        
                SSLOptions +StdEnvVars
        
        
                SSLOptions +StdEnvVars
        

        BrowserMatch ".*MSIE.*" \
                nokeepalive ssl-unclean-shutdown \
                downgrade-1.0 force-response-1.0
	
Attention : il s'agit des exemples pour Debian Jessie + Apache2.4 - pour Wheezy c'est légèrement différent.

Pour tester ton config :
Code:
apache2ctl configtest
apache2ctl -S
avant de redémarrer apache2.

Lolothomas
04/10/2015, 21h11
Bonjour à tous je recherche un peu d'aide pour mettre en place 3 domaines sur 3 Ip failover merci lolo