OVH Community, votre nouvel espace communautaire.

mail : sh OK mais php HS ...


sloomy
17/02/2016, 06h44
Bonjour,

Pareil si tu as besoin d'aide, n’hésite pas a me contacter en message privé.

Cordialement,
Bruno

freemaster
16/02/2016, 21h16
je ne sais pas du tout ce que tu as comme config, et si je pourrais aider...
mais si tu m'envoies un mail, via mon site en signature, section support -> Nous contacter
je peux éventuellement jeter un oeil

benoit07
16/02/2016, 21h11
pas mieux pour qmail !
smtp ... je vais essayer de trouver ça ...

merci

freemaster
16/02/2016, 21h09
tu peux essayer d'ouvrir un ticket... mais serveur dédié, tu vas te faire jeter je pense

benoit07
16/02/2016, 21h02
y a t il un moyen de demander une assistance technique à OVH ?? je suis incapable de débloquer le problème et j'ai des clients hébergés sur le site ...
merci

freemaster
16/02/2016, 21h01
sans doute parce que tu n'utilises pas postfix ou exim4...
qmail ? regardes si t'as un /var/log/qmail/current
sinon faudrait savoir ce que c'est ton serveur smtp

benoit07
16/02/2016, 20h55
bonsoir (3ème message que je fais, les 2 précédents n'ont pas étés validés ?)
je n'ai touché à rien sur la configuration du serveur (je n'y connais rien ...)
je n'ai pas de fichier mail.info dans /var/log/
cordialement

benoit07
15/02/2016, 13h25
bonjour et merci pour ta réponse.
ça marchait avant ... mais je n'ai, à priori, rien fait entre temps, je suis trop nul en administration serveur pour tenter quoi que ce soit ...
je n'ai pas de fichier mail.info par contre.

nota : webmin envoie des emails sans souscis, fail2ban aussi (j'aimera bien les arreter d'ailleurs ...)
nota2 : je ne retrouve rien avec cette interface de webmin, l'ancienne me semblait plus simple et compréhensible ...

je suis perdu et OVH ne propose aucune intervention ...

Merci

pour info, quand j'envoie un mail avec php : dans /var/log/maillog, tout ça s'ajoute :

Feb 15 15:15:43 ns313955 postfix/pickup[29004]: 9DCB6D52EE: uid=505 from=
Feb 15 15:15:43 ns313955 postfix/cleanup[1272]: warning: connect to Milter service inet:localhost:8891: Connection refused
Feb 15 15:15:43 ns313955 postfix/cleanup[1272]: 9DCB6D52EE: message-id=<20160215141543.9DCB6D52EE@ns313955.ip-37-59-12.eu>
Feb 15 15:15:43 ns313955 postfix/qmgr[3268]: 9DCB6D52EE: from=, size=387, nrcpt=1 (queue active)
Feb 15 15:15:43 ns313955 postfix/smtp[1281]: 9DCB6D52EE: to=, relay=gmail-smtp-in.l.google.com[2a00:1450:400c:c04::1b]:25, delay=0.12, delays=0.07/0/0.04/0.01, dsn=5.1.2, status=bounced (host gmail-smtp-in.l.google.com[2a00:1450:400c:c04::1b] said: 553 5.1.2 The sender address is not a valid RFC-5321 address. 134si25501497wmj.75 - gsmtp (in reply to MAIL FROM command))
Feb 15 15:15:43 ns313955 postfix/cleanup[1272]: BC448D52EF: message-id=<20160215141543.BC448D52EF@ns313955.ip-37-59-12.eu>
Feb 15 15:15:43 ns313955 postfix/qmgr[3268]: BC448D52EF: from=<>, size=2439, nrcpt=1 (queue active)
Feb 15 15:15:43 ns313955 postfix/bounce[1282]: 9DCB6D52EE: sender non-delivery notification: BC448D52EF
Feb 15 15:15:43 ns313955 postfix/trivial-rewrite[1411]: warning: do not list domain ns313955.ip-37-59-12.eu in BOTH mydestination and virtual_mailbox_domains
Feb 15 15:15:43 ns313955 postfix/qmgr[3268]: 9DCB6D52EE: removed

benoit07
12/02/2016, 19h17
avant rien de particulier en fait
alors j'ai pas de mail.info dans le répertoire /var/log/

à tout hasard j'ai ce fichier là ...

[root@ns313955 ~]# tail -f /var/log/maillog
Feb 12 21:17:16 ns313955 postfix/qmgr[3268]: 4DEB3D52D2: from=<>, size=2532, nrcpt=1 (queue active)
Feb 12 21:17:16 ns313955 postfix/trivial-rewrite[5844]: warning: do not list domain ns313955.ip-37-59-12.eu in BOTH mydestination and virtual_mailbox_domains
Feb 12 21:17:16 ns313955 postfix/qmgr[3268]: 43333D52D1: from=<>, size=2440, nrcpt=1 (queue active)
Feb 12 21:17:16 ns313955 dovecot: lda(jfb): Error: user jfb: Initialization failed: mail_location not set and autodetection failed: Mail storage autodetection failed with home=/home/jfb
Feb 12 21:17:16 ns313955 dovecot: lda(jfb): Fatal: Invalid user settings. Refer to server log for more information.
Feb 12 21:17:16 ns313955 dovecot: lda(jfb): Error: user jfb: Initialization failed: mail_location not set and autodetection failed: Mail storage autodetection failed with home=/home/jfb
Feb 12 21:17:16 ns313955 dovecot: lda(jfb): Fatal: Invalid user settings. Refer to server log for more information.
Feb 12 21:17:16 ns313955 postfix/local[5848]: 4DEB3D52D2: to=, orig_to=, relay=local, delay=76197, delays=76197/0.01/0/0.06, dsn=4.3.0, status=deferred (temporary failure)
Feb 12 21:17:16 ns313955 postfix/local[5849]: 43333D52D1: to=, orig_to=, relay=local, delay=76197, delays=76197/0.01/0/0.05, dsn=4.3.0, status=deferred (temporary failure)
Feb 12 21:22:22 ns313955 clamd[3153]: SelfCheck: Database status OK.

freemaster
12/02/2016, 11h04
cela marchait avant... mais avant quoi ? aucun changement n'a été opéré sur le serveur ?

sinon lors d'un test d'envoi via php, un tail -f /var/log/mail.info histoire de voir ce qui se passe

benoit07
11/02/2016, 22h07
bonjour, j'ai un petit soucis sur mon serveur.
je peux envoyer des emails avec la commande mail, directement en ligne de commande.
par contre, depuis quelques temps, les scripts PHP dans lesquels la fonction mail est utilisée ne fonctionnement pas.
rien n'est envoyé.
j'ai essayé dans le script la commande :
system ( echo .... | mail -s ...) mais ça ne fonctionne pas non plus ...

j'avoue ne rien comprendre, je ne suis pas expert ... ça fonctionnait parfaitement avant pourtant !

Merci pour vos avis éclairés ...

benoit