OVH Community, votre nouvel espace communautaire.

Probleme avec la contrib Cpanel


phil
22/02/2014, 09h54
As-tu passé ces commandes pendant la coupure apache?

Sinon, essaye de voir aussi les graphes du serveur depuis la console OVH. Utilisation CPU, bande passante etc. Est-ce que tu as une consommation excessive pendant les coupures? C'est pratique aussi d'avoir un munin ou équivalent: exemple pour analyser l'origine du problème.

Enfin dernière question, as-tu modifié quelque chose sur ton serveur juste avant de constater ces problèmes? MAJ cpanel ou autre?

Philippe

jarod6827
22/02/2014, 08h45
Bonjour,

je n'ai pas de cat /var/log/apache2/error.log sur mon serveur page vide

root@ns3314135 [~]# netstat -ntpul | grep httpd
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 19231/httpd
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 19231/httpd

root@ns3314135 [~]# ps aux | grep httpd
root 19231 0.0 0.0 67012 3960 ? Ss Feb21 0:03 /usr/local/apache/bin/httpd -k start -DSSL
nobody 24198 0.0 0.0 67152 3372 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 24484 0.0 0.0 67152 3384 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 24574 0.0 0.0 67152 3356 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 24701 0.0 0.0 67152 3376 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 24714 0.0 0.0 67152 3332 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 24856 0.0 0.0 67152 3352 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 24867 0.0 0.0 67152 3368 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 25020 0.0 0.0 67288 3496 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 25026 0.0 0.0 67152 3444 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 25158 0.0 0.0 67152 3336 ? S 09:34 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 25173 0.0 0.0 0 0 ? Z 09:34 0:00 [httpd]
nobody 29360 0.0 0.0 67152 3348 ? S 09:37 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 31621 0.0 0.0 67152 3292 ? S 09:42 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 31655 0.0 0.0 67152 3320 ? S 09:42 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 31656 0.0 0.0 67288 3376 ? S 09:42 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 31764 0.0 0.0 67152 3316 ? S 09:42 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 31973 0.0 0.0 67152 3312 ? S 09:43 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 32201 0.0 0.0 67152 3292 ? S 09:43 0:00 /usr/local/apache/bin/httpd -k start -DSSL
nobody 32214 0.0 0.0 67152 3072 ? S 09:43 0:00 /usr/local/apache/bin/httpd -k start -DSSL
root 32340 0.0 0.0 103288 828 pts/0 R+ 09:44 0:00 grep httpd
root@ns3314135 [~]#

voila ce que les commandes me donnes

j'ai aussi constatez que le serveur Mysql ce coupe aussi car souvent sur mon site j'ai connexion impossible

phil
21/02/2014, 21h16
Sinon ya ça aussi: http://kb.liquidweb.com/locations-of...panel-servers/

Sur mon serveur, je trouve dans les logs d'erreur:
Code:
:~# cat /var/log/apache2/error.log 
[Fri Feb 21 20:35:04 2014] [notice] Apache/2.2.22 (Debian) configured -- resuming normal operations
[Fri Feb 21 20:35:05 2014] [notice] caught SIGTERM, shutting down
[Fri Feb 21 20:35:06 2014] [notice] Apache/2.2.22 (Debian) PHP/5.4.4-14+deb7u7 configured -- resuming normal operations
[Fri Feb 21 20:35:17 2014] [notice] Graceful restart requested, doing restart
Donc l'arrêt/relance du serveur devrait apparaître. Sinon va voir la conf apache ( /usr/local/apache/conf) et force à la main un verbose plus important. Ou si cPanel le permet, fais la modif depuis. Dans tous les cas, arrêt/relance d'apache après.

Sinon, qu'est-ce qui te fait dire qu'apache se coupe? Tu constate que ton site web n'est plus dispo? A ce moment là, tu peux essayer immédiatement:
  1. telnet @ip_serveur 80 et tape "get /"
  2. connecte-toi en ssh et tape
    • netstat -ntpul | grep httpd
    • ps aux | grep httpd

Bref, essaye de voir si apache tourne toujours, s'il écoute bien sur le port 80 et s'il répond à une requête http.

Philippe

jarod6827
21/02/2014, 19h28
oui je sais j'avais trouver cependant a part des petits erreurs de fichier qui manque ça me dit pas d’où viens ce problème le pire c'est qu'avec 3 serveur ca fait pareil

phil
21/02/2014, 17h35
google cpanel httpd logs !!
=> http://docs.cpanel.net/twiki/bin/vie...lDocs/ErrorLog

Un serveur dédié n'est pas un Kinder Surprise. Il faut lire la doc !

jarod6827
21/02/2014, 16h04
je vois ca ou lol desoler

phil
21/02/2014, 16h01
Consulte les logs?

Philippe

jarod6827
21/02/2014, 15h37
Bonjour,

J'ai installer Cpanel sur mon serveur, et depuis quelque temps le serveur Mysql et Httpd coupe sur des petites périodes dans la journée.

Merci a tous pour vos conseils