OVH Community, votre nouvel espace communautaire.

probleme de connection via Putty sur container LXC créé avec proxmox 4,


freemaster
25/03/2016, 18h17
la console noVNC n'est pas une connexion ssh... et PermitRootLogin ne concerne que l'user root, avec un autre user tu aurais pu te connecter
sinon si tu utilisais une ancienne version de putty, tu n'aurais pas eu non plus "acces denied"

Miroslav
25/03/2016, 07h28
Bonjour,

Tout d'abord merci pour vos réponses.
Le problème venait en effet de la config ssh, j'ai donc changé le PermitRootLogin without-password en PermitRootLogin yes, puis redémarré le service ssh ... et maintenant ça marche ;-).
Pour ma compréhension, pourquoi la connexion fonctionnait bien avec un user/mot de passe via la console noVNC et pas via Putty ?

Encore Merci de votre aide.

bbr
25/03/2016, 05h37
as-tu la dernière version de Putty ? Cela pourrait expliquer ton problème.

freemaster
25/03/2016, 03h34
sans doute parce que tu essaies de te connecter en root ?
modifier le fichier /etc/ssh/sshd_config
pour remplacer permitrootlogin without-password par permitrootlogin yes
ou alors tu utilises des clés ssh

Miroslav
24/03/2016, 22h06
Bonjour,

Je viens de louer un serveur SYS, et j'ai effectué l'installation automatique de proxmox 4 / debian 8 depuis la console Soyoustart.
Avant de commencer à installer des CT et autres logiciels, j'ai tout d'abord fait les mises à jour du systeme sur le serveur physique (apt-get update / apt-get upgrade) pour avoir tout à jour avant de commencer.

Après connexion à Proxmox et pour la création du container LXC :
- location d'une adresse IP Failover avec création d'une MAC virtuelle
- création du container.
- connexion via la console noVNC.
- Mises à jour standard (apt-get update / apt-get upgrade)
- le probleme : impossible de se connecter au CT via Putty : j'ai un message "access denied" lorsque je valide le mot de passe.

J'ai utilisé, entre autre, le tutoriel special ovh trouvé sur le wiki de proxmox : https://pve.proxmox.com/wiki/OVH. (voir le chapitre "LXC container")
il y est dit : "Inside a Debian container, this creates automatically the following /etc/network/interfaces file: "

et en vérifiant sur le nouveau CT (via la console noVNC) le fichier "interfaces" est bien conforme au tutoriel.

Quelqu'un aurait-il un retour d'expérience ou éventuellement des pistes de recherche pour comprendre pourquoi je ne peux pas me connecter via Putty ?

Merci d'avance.