OVH Community, votre nouvel espace communautaire.

Petit soucis avec madm :o((


oli65
06/06/2016, 19h57
Bonsoir,

J'ai commencé a installer il y 48h00 un E3-SSD-3 (SYS) donc avec 3 disque SSD. Lors de l'installation du systeme (ubuntu), l'interface ovh pour le partitionnement des disques a exigé un RAID1 pour le système, j'ai donc respecté cette directive ). Par contre, j'ai créé 3 autres partions
en RAID 5 (cool).
Aujourd'hui lors de l'installation de mon server mail (j'en été seulement à postfix, j'ai eu un premier message très rapidement... grande surprise
il venait de mdadm.. Je me suis empressé à le lire avec un simple cat...
Mauvaise surprise venant mdadm...

>>This is an automatically generated mail message from mdadm running on mail1
A DegradedArray event had been detected on md device /dev/md1.
Faithfully yours, etc.
P.S. The /proc/mdstat file currently contains the following:
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath] [faulty]
md1 : active raid1 sdc1[2] sda1[0]
20478912 blocks [3/2] [U_U]
md2 : active raid5 sdb2[1] sdc2[2] sda2[0]
10482688 blocks level 5, 512k chunk, algorithm 2 [3/3] [UUU]
md5 : active raid5 sdb5[1] sdc5[2] sda5[0]
152017920 blocks level 5, 512k chunk, algorithm 2 [3/3] [UUU]
md6 : active raid5 sdb6[1] sdc6[2] sda6[0]
20474880 blocks level 5, 512k chunk, algorithm 2 [3/3] [UUU]
unused devices: "

donc petit soucis sur md1 (partition du systeme en raid1, pfffffff)

J'ai donc controlé les 3 disques via smartctl -a /dev/sda (b et c). Apparemment pas de soucis au niveau des disques.
J'ai également interroger mdadm (alias la canaille).
=># mdadm --misc --detail /dev/md1
"/dev/md1:
Version : 0.90
Creation Time : Sat Jun 4 14:53:33 2016
Raid Level : raid1
Array Size : 20478912 (19.53 GiB 20.97 GB)
Used Dev Size : 20478912 (19.53 GiB 20.97 GB)
Raid Devices : 3
Total Devices : 2
Preferred Minor : 1
Persistence : Superblock is persistent

Update Time : Mon Jun 6 18:46:06 2016
State : clean, degraded
Active Devices : 2
Working Devices : 2
Failed Devices : 0
Spare Devices : 0

UUID : f363a998:b8927495:a4d2adc2:26fd5302
Events : 0.14266

Number Major Minor RaidDevice State
0 8 1 0 active sync /dev/sda1
1 0 0 1 removed
2 8 33 2 active sync /dev/sdc1"

On constate que State est "clean, degraded". J'ai redémarrer le serveur en mode RESCUE pour consulter les logs dans l'interface WEB.
Mais bon, ça ne m'a pas rendu service car il s'agit simplement de smartctl. Puis redémarrage du serveur en mode Disque.
Le temps d'écrire ce post, j'ai reçu un autre message de madm (grr il a décidé de m'embêter lolll).. Me donnant le même message que ce matin.
- Est ce un faux positif.. ou plutôt une fausse alerte.. car le fait du passage du mode rescue vers le mode disque (car hier j'ai pratiqué un
contrôle du hardware via le mode rescue dans l'interface web de test avant de foncer dans l'installation du serveur) ?
- Est ce une fausse erreur car le système est sur un RAID1 et les autres partitions en RAID5 ?
- Ces questions car il s'agit d'une nouvelle installation et si le raid est effectivement déjà dégradé.. ça craint beaucoup pour l'avenir au
niveau fiabilité du serveur.
Je dépose donc ce post pour avoir un avis d'un expert en RAID software (qui a déjà eu le même soucis lors de l'installation sur un systeme 3
disques et utilisant un RAID1 pour le systeme et un RAID5 pour les autres partitions)

Merci d'avance
Bonne soirée