OVH Community, votre nouvel espace communautaire.

Ajout site avec IP dédié sur ISPConfig


Nowwhat
27/06/2016, 21h55
Ca l'air ok.
Ton IPFO repond au ping ....

Le ssh répond quand j'utilise ssh sur ton IP et IPFO avec le même 'fingerprint'.

Coté IP, tout me semble bon.

Yacine
26/06/2016, 18h05
Citation Envoyé par Nowwhat
Post ton
/etc/network/interfaces
stp.
Voilà voilà merci !

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 91.121.72.84
        netmask 255.255.255.0
        network 91.121.72.0
        broadcast 91.121.72.255
        gateway 91.121.72.254
        post-up /sbin/ifconfig eth0:0 5.39.122.179 netmask 255.255.255.255 broadcast 5.39.122.179
        post-down /sbin/ifconfig eth0:0 down

iface eth0 inet6 static
        address 2001:41d0:1:7d54::
        netmask 64
        post-up /sbin/ip -family inet6 route add 2001:41d0:1:7dff:ff:ff:ff:ff dev eth0
        post-up /sbin/ip -family inet6 route add default via 2001:41d0:1:7dff:ff:ff:ff:ff
        pre-down /sbin/ip -family inet6 route del default via 2001:41d0:1:7dff:ff:ff:ff:ff
        pre-down /sbin/ip -family inet6 route del 2001:41d0:1:7dff:ff:ff:ff:ff dev eth0

Nowwhat
26/06/2016, 13h01
Post ton
/etc/network/interfaces
stp.

Yacine
26/06/2016, 10h24
Comme tu le dis, ISPConfig est une interface graphique.
J'ai toujours accès à mon serveur sous Debian, l'un comme dans l'autre, je n'arrive pas à résoudre mon soucis.

Je ne suis tombé dans aucun piège. J'ai fait un choix qui est le mien. Merci pour ton aide.

Nowwhat
24/06/2016, 22h26
Citation Envoyé par Yacine
..... pas à trouver de solution pour un besoin aussi basique
Car t'es tombé dans un piège.

T'as un serveur.
T'as un site web, ou plusieurs.
T'as un nom de domaine, ou plusieurs.
T'as un IPv4 ou plusieurs.

Dans ce cas, t'es obligé .... Non, OBLIGE de savoir ce que c'est:
Un serveur web comme apache2 ou inginx,
bind - le serveur DNS sur ton serveur, soir savoir paramétrer le tout dans le "Manager d'OVH" - ou ailleurs tous ce que lié à ta "zone" (de ton nom de domaine) soit tes zones,

L'idée de "prendre ISPConfog" et en suite t'as pas besoin de savoir ce que c'est, le DNS, ou "serveur web", c'est un gros erreur. Ça ne va pas le faire.

Là, ton choix est fait :
Tu doit comprendre comment ça fonctionne le "DNS" : ce qui va en suite t'aider à vérifier le paramétrage et faire des rectifications si nécessaire.
Paramétrer et vérifier ton serveur web,
en en suite:
savoir comment faire tout ça avec ISPConfig.
Sachant que ISPConfig ne va pas tout faire, il est donc nécessaire de tout comprendre - avant qui tu puisse travailler avec.

Moi, je me suis décidé depuis longtemps : j'ai enlevé ISPConfig de cette équitation.
Comme ça, il me reste moins à appendre.
Puis, les programmes comme Apache2 ou enginx - ou 'bind', ou 'postfix' ils sont hyper bien documenté,té sur le net. Toutes les configurations sont déjà testé, toutes les problèmes ont déjà été découvert, leur solution sont déjà la.
Avec ISPConfig, sachant qu'il s'agit d'un interface 'graphique', il te reste qu'une solution : potager dans leur doc ....

Yacine
24/06/2016, 19h22
Citation Envoyé par bbr
non le reverse n'est pas le problème puisqu'il n'est pas obligatoire d'en mettre un, par contre pour le mettre il faut :
- que le domaine soit sur le serveur/ip
- qu'il ait été retiré des DNS secondaires du précédent serveur
- que tu ajoutes le code que le manager te donne dans la zone DNS du domaine
Merci pour ta réponse.
Mon prblème n'est toujours pas résolu. C'est tout de même dingue que je n'arrive pas à trouver de solution pour un besoin aussi basique

bbr
23/06/2016, 06h35
non le reverse n'est pas le problème puisqu'il n'est pas obligatoire d'en mettre un, par contre pour le mettre il faut :
- que le domaine soit sur le serveur/ip
- qu'il ait été retiré des DNS secondaires du précédent serveur
- que tu ajoutes le code que le manager te donne dans la zone DNS du domaine

Yacine
22/06/2016, 18h53
Citation Envoyé par websahib
Ouip il est possible en effet que j'ai eu la comprenette qui a trébuché !! Désolé !

Ceci dit le message et le problème restent d'actualité !
Oui mon problème reste d'actualité :/
Sur la partie admin de SyS je n'arrive pas à ajouter un reverse à mon IP failover, est-ce cela le problème ?

websahib
21/06/2016, 09h35
Ouip il est possible en effet que j'ai eu la comprenette qui a trébuché !! Désolé !

Ceci dit le message et le problème restent d'actualité !

bbr
20/06/2016, 18h36
Citation Envoyé par websahib
Un truc tout bête, si tu utilises le fail over, tu as recopié tes fichiers et données sur le 2ème serveur ... logique hein ?
Non pas logique, tant que ne fait pas de migration cela n'a aucune incidence

websahib
20/06/2016, 18h32
Un truc tout bête, si tu utilises le fail over, tu as recopié tes fichiers et données sur le 2ème serveur ... logique hein ?
Par contre as-tu vérifié le propriétaire et les droits d'accès à web !!
Parce que moi je me suis fait pigeonner par ce détail machiavélique !!

Yacine
20/06/2016, 09h42
Citation Envoyé par Nowwhat
Bonjour,

Le DNS est à modifier bien sur.

E aussi informer apache2 qu'il utilise LE BON IP pour le bon site.
A éditer :
/etc/apache2/ports.conf
et
/etc/apache2/sites-enabled/xxxxx (le fichier vconfig de ton site)
puis surtout PAS redémarrer apache2, mais d'abord (toujours) :
apache2ctl configtest
et SI le résultat est
Syntax OK
Redémarrer apache2
apache2ctl graceful
puis isnpecter les logs d'apache pour voir si il est bien démarré et tout content

En suite : autre vérification :
netstat -napt | grep ':80'
pour vérifier que apache2 écoute bien sur le BON IP (ton IPFO - et, si souhaité, plus du tout sur l'IP du serveur)


Je ne sais pas du tout comment ça ce fait avec ISPConfig.
J’appris à travailler avec "apache2", pas "apache2 et ISPConfig" (pourquoi apprendre plus que nécessaire ? - et sachant que le doc de apache2 est et reste indispensable)
Tout est bien configuré niveau apache2. ISPConfig le fait très bien. J'ai vérifié avec tes lignes de commandes et tout est bon à priori

Yacine
20/06/2016, 09h38
Citation Envoyé par sloomy
Bonjour,

La résolution dns est la bonne ?

Cdlt
Bruno
J'ai bien créer le DNS avec la bonne idée IP.
Pièce jointe 79

Sachant que j'ai acheter le NDD chez 4x.fr et que j'ai fait la config suivante :
Pièce jointe 80

Je ne vois pas ce qui bloque niveau DNS ?


Merci !

Nowwhat
20/06/2016, 07h43
Bonjour,

Le DNS est à modifier bien sur.

E aussi informer apache2 qu'il utilise LE BON IP pour le bon site.
A éditer :
/etc/apache2/ports.conf
et
/etc/apache2/sites-enabled/xxxxx (le fichier vconfig de ton site)
puis surtout PAS redémarrer apache2, mais d'abord (toujours) :
apache2ctl configtest
et SI le résultat est
Syntax OK
Redémarrer apache2
apache2ctl graceful
puis isnpecter les logs d'apache pour voir si il est bien démarré et tout content

En suite : autre vérification :
netstat -napt | grep ':80'
pour vérifier que apache2 écoute bien sur le BON IP (ton IPFO - et, si souhaité, plus du tout sur l'IP du serveur)


Je ne sais pas du tout comment ça ce fait avec ISPConfig.
J’appris à travailler avec "apache2", pas "apache2 et ISPConfig" (pourquoi apprendre plus que nécessaire ? - et sachant que le doc de apache2 est et reste indispensable)

sloomy
20/06/2016, 06h41
Bonjour,

La résolution dns est la bonne ?

Cdlt
Bruno

Yacine
19/06/2016, 22h24
Citation Envoyé par websahib
Bonjour,
La configuration indiquée ne fonctionne qu'à moitié, il faut modifier le fichier interfaces pour pleinement profiter de l'ip FO !
regarde dans les how-to de bbr tu trouveras ton bonheur !
J'ai eu le même problème et après modification du fichier interfaces : miracle !!

Salut,

Alors j'ai bien suivi le tutoriel et j'ai donc modifier le fichier interfaces.
A présent j'arrive à pinger l'adresse IP. Mais je n'arrive toujours pas à accéder au site :/

Merci pour votre aider !

websahib
19/06/2016, 15h41
Bonjour,
La configuration indiquée ne fonctionne qu'à moitié, il faut modifier le fichier interfaces pour pleinement profiter de l'ip FO !
regarde dans les how-to de bbr tu trouveras ton bonheur !
J'ai eu le même problème et après modification du fichier interfaces : miracle !!

bbr
17/06/2016, 20h50
que donne ceci ?
Code:
ifconfig
sinon ton ispconfig est sur quelle distribution ?
recherche dans les docs d'ovh pour installer ton IPFO, il me semble que tu as le lien dans le mail envoyé lors de la commande ( http://guides.ovh.com/AjouterAliasIp )

Yacine
17/06/2016, 18h35
Citation Envoyé par bbr
dans /etc/network/interfaces tu as configuré ton IPFO ?
elle pingue ?
Non je n'ai pas touché au fichier interfaces. J'ai uniquement utilisé la GUI de ISPConfig.
Et je n'arrive pas à la pinguer non plus.

Merci

bbr
17/06/2016, 17h10
dans /etc/network/interfaces tu as configuré ton IPFO ?
elle pingue ?

Yacine
17/06/2016, 15h26
Bonjour à tous,

J'ai acheter un NDD que j'aimerai héberger sur mon serveur dédié avec un IP qui lui est propre.
J'ai donc demandé une IP failover à cet effet.

J'administre mon serveur via ISPConfig. Ci-dessous les étapes que j'ai suivi :

1- Création de l'IP failover sur mon espace SoYouStart
2- Création de l'IP au sein d'ISPConfig
3- Création du site sur ISPConfig avec la bonne IP
Pièce jointe 77
4- Création d'une Zone DNS pour mon site.
Pièce jointe 78
5- J'ai acheter mon NDD sur 4x.fr et j'ai bien indiqué le NS1 créé à l'étape 4 et le NS2 d'OVH.
6- J'ai créé un DNS secondaire sur l'espace SoYouStart et le test 'ownercheck' est passé.

Le proclème c'est que le site n'est pas du tout reconnu. Je ne sais pas du tout à quelle étape ça bloque.

NB: pour l'ip créée je n'arrive pas à définir de reverse sur l'espace SoYouStart.
Ca vient peut être de là ?

Vous avez une quelconque idée ?

merci !