OVH Community, votre nouvel espace communautaire.

IP Failover et pFSense


Style
26/06/2014, 17h26
Bonjour,

Oui mon problème est résolu. Il y avait un problème de routage de la part de SYS (comme freeman2706).

Cependant par rapport à ce qui est indiqué dans le post de ndyserinck, le script fonctionnel sur ma version pfSense est le suivant (ne pas mettre de i à -net) :
/sbin/route add -net IPHOST.254/32 -link -iface emX
/sbin/route add default IPHOST.254

freeman2706
04/06/2014, 20h46
Bonjour,

Entre temps, j'ai contacté le support (VM sous Pfsense, ubuntu et windows) correctement configuré y'avais pas de raison, et finalement ils m'ont avoué qu'"Une erreur de routage de l'adresse MAC était effectivement présente."

Sa pourra servir pour ceux qui on aussi le même problème

kalistyan
04/06/2014, 17h45
Salut,

J'ai monté une VM pfSense, et tout fonctionne correctement. Pour cela, j'ai suivi le tuto suivant : http://www.gameoverblog.fr/?p=2031

freeman2706
02/06/2014, 16h14
Bonjour,

Votre problème est-il résolu ?
J'ai exactement le même problème.

J'ai tenté après avec un ubuntu. après la bonne configuration

Code:
auto lo eth0
iface lo inet loopback
iface eth0 inet static
address IP.FAIL.OVER
netmask 255.255.255.255
broadcast IP.FAIL.OVER
post-up route add GATEWAY_VM dev eth0
post-up route add default gw GATEWAY_VM
pre-down route del GATEWAY_VM dev eth0
pre-down route del default gw GATEWAY_VM
Et
Code:
nameserver 213.186.33.99
dans resolv.conf

déjà je n'arrive pas à pinger la passerelle. (J'ai bien remplacé "GATEWAY_VM" par 188.1xx.2xx.254) que ce soit via pfsense, comme ubuntu

Mon ip (ESXi): 188.1xx.2xx.1xx
Mon IP FO: 46.1xx.xx.xxx
Serveur: SYS-IP-4

J'ai bien mis la bonne @mac, et entré le bon nom de VM, et j'ai regénéré 3 fois une nouvelle @mac

Cordialement

ndyserinck
21/04/2014, 21h11
Salutations,

Ta config est bonne.
Pense bien a mettre l'ip FAILOVER en /32 dans pfsense sinon le Failover ne passe pas.
Au login screen tu devrais avoir quelque chose comme ceci :

Code:
*** Welcome to pfSense 2.1.2-RELEASE-pfSense (amd64) on firewall1 ***

 WAN (wan)       -> em2        -> v4: IP_FAILOVER/32
 LAN (lan)       -> em0        -> v4: LAN1/24
 OPT1 (opt1)     -> em1        -> v4: OPT1/24

 0) Logout (SSH only)                  8) Shell
 1) Assign Interfaces                  9) pfTop
 2) Set interface(s) IP address       10) Filter Logs
 3) Reset webConfigurator password    11) Restart webConfigurator
 4) Reset to factory defaults         12) pfSense Developer Shell
 5) Reboot system                     13) Upgrade from console
 6) Halt system                       14) Disable Secure Shell (sshd)
 7) Ping host                         15) Restore recent configuration
Enter an option: 8

Astuce : Ajoute un script au boot de ta machine pfsense afin que les routes soient correctement prises en charge dès son boot
Chemin du script : /usr/local/etc/rc.d/myroutes.sh
Exemple :
Code:
#!/bin/sh

/sbin/route add -inet IPHOST.254/32 -link -iface em2
/sbin/route add default IPHOST.254
(dans mon cas l'interface qui à l'IP failover est EM2, vérifie tes paramètres.)

LautreCon
20/04/2014, 00h13
J'ai fais le même type d'install sur XenServer (et je vais la refaire sur ESX).
Il faut que l'interface em0 utilise la carte réseau de l'hote (VM NETWORK par defaut).
Ensuite tu configure ton interface comme tu as fait, vérifie bien que ton mask est 255.255.0.0 ( /16 je crois).

Ca devrait fonctionner.

Style
18/04/2014, 19h08
Bonjour,

J'ai récemment acquis un SYS-E32-1 sur lequel est installé ESXi 5.0 U1.
Je souhaite utiliser une VM pFSense qui fera office de passerelle pour les VMs du LAN. Pour cela, j'ai configuré pFSense avec deux interfaces (em0 pour le WAN et em1 pour le LAN, chacune étant sur un vSwitch différent).
L'interface em0 a comme adresses IP et MAC celles de l'IP FailOver fournies par SYS.

J'ai enfin configurer la passerelle avec les commandes suivantes :
route add -net IP_ESXi.254/32 -iface em0
route add default IP_ESXi.254

Seulement ma VM pFSense n'accède pas au réseau WAN.
Je ne sais pas si cela peut venir de là mais je ne peux pas pinger IP_ESXi.254 depuis une machine d'Internet mais je peux depuis l'ESXi. Mauvaise configuration de SYS ou bien dans ma config ?

Merci