OVH Community, votre nouvel espace communautaire.

PB avec SASL


elekaj34
14/09/2014, 08h23
Merci pour ton aide,

Pour saslauth, le ps ax me donne bien :
4250 ? S 0:00 /usr/sbin/saslauthd -a pam -c -r -m /var/spool/postfix/var/run/saslauthd -n 5
L'user postfix appartient au groupe sasl (j'ai vérifié).

Quand je me connecte sur le port 587 j'ai ceci (sur le port 25, j'ai la même erreur) :
saslauthd[6072] :rel_accept_lock : released accept lock
saslauthd[6072] :cache_get_rlock : attempting a read lock on slot: 1361
saslauthd[6072] :cache_lookup : [login=elekaj34@domain.net] [service=domain.net] [realm=smtp]: not found, update pending
saslauthd[6070] :get_accept_lock : acquired accept lock
saslauthd[6072] :cache_un_lock : attempting to release lock on slot: 1361
saslauthd[6072] :do_auth : auth failure: [user=elekaj34@domain.net] [service=smtp] [realm=domain.net] [mech=pam] [reason=PAM auth error]
saslauthd[6070] :rel_accept_lock : released accept lock
saslauthd[6070] :cache_get_rlock : attempting a read lock on slot: 1361
saslauthd[6070] :cache_lookup : [login=elekaj34@jupin.net] [service=domain.net] [realm=smtp]: not found, update pending
saslauthd[6070] :cache_un_lock : attempting to release lock on slot: 1361
saslauthd[6073] :get_accept_lock : acquired accept lock
saslauthd[6070] :do_auth : auth failure: [user=elekaj34@domain.net] [service=smtp] [realm=domain.net] [mech=pam] [reason=PAM auth error]
Et aucune connexion à la BDD mysql
Oui j'ai commencé à faire une fixation la dessus

Et bingo, ce n'est pas dans la config qui fallait chercher, mais en comparant les paquets contenant sasl, pam et sql entre les deux serveurs, je me suis aperçu qu'il manquait le paquet "libpam-mysql"

Voilà la donc la bourde réparée et maintenant SASL fonctionne bien
Merci nowhat pour ta patience et ton aide

Nowwhat
13/09/2014, 23h18
Citation Envoyé par elekaj34
Code:
# WARNING: DO NOT SPECIFY THE -d OPTION.
# The -d option will cause saslauthd to run in the foreground instead of as
# a daemon. This will PREVENT YOUR SYSTEM FROM BOOTING PROPERLY. If you wish
# to run saslauthd in debug mode, please run it by hand to be safe.
Ouvre deux sessions ssh.
Dabns session 1:

Exécute un
ps ax | grep 'saslauthd'
pour trouve le ligne de commande de saslauthd
Chez moi, c'est
/usr/sbin/saslauthd -a pam -c -r -m /var/spool/postfix/var/run/saslauthd -n 5
Puis arrête saslauthd:
service stop saslauthd

et démarre le "à la main" comme ça:
/usr/sbin/saslauthd -d -a pam -c -r -m /var/spool/postfix/var/run/saslauthd -n 5
Tant que tu Cltrl-C pas, saslauthd va tourner dans ta session ssh avec les details.

Dans session 2 de ssh
service postfix restart

-------------------

Maintenant, utilise un client mail pour envoyer un mail (qui utilise bien sur porte 587 ou 995).

T'aura ceci dans le fenêtre session 1:
saslauthd[5768] :cache_lookup : [login=postmaster@papy-team.org] [service=papy-team.org] [realm=smtp]: not found, update pending
saslauthd[5768] :cache_un_lock : attempting to release lock on slot: 1353
saslauthd[5768] :cache_get_wlock : attempting a write lock on slot: 1353
saslauthd[5768] :cache_commit : lookup committed
saslauthd[5768] :cache_un_lock : attempting to release lock on slot: 1353
saslauthd[5768] :do_auth : auth success: [user=postmaster@papy-team.org] [service=smtp] [realm=papy-team.org] [mech=pam]
saslauthd[5768] :do_request : response: OK
Concernant le [service=smtp]
T'as bien un
/etc/pam.d/smtp:
auth required pam_mysql.so user=mail passwd=postfixmail host=127.0.0.1 db=mail table=users usercolumn=email passwd column=xxxx crypt=1 debug=0 verbose=0
account sufficient pam_mysql.so user=mail passwd=postfixmail host=127.0.0.1 db=mail table=users usercolumn=email passwd column=xxxx crypt=1 debug=0 verbose=0
Bien sur, ma base des données, table, et column peuvent être différent chez toi.

Exemple parmi des milliers: http://memo-linux.com/sasl-pour-postfix/

T'as vu le debug=0 et verbose=0
Encore plus des possibilités pour voir ce qui ce passe.

elekaj34
13/09/2014, 18h54
Re,

Je sais pas si c'est normal, mais avec la commande tcpdump port 3306, je vois passer les connections à mysql quand je me connecte en IMAP, mais lorsque j'essaye d'envoyer un message via SASL, aucune connection n'est faite au serveur SQL

Bref, ca coince avant même que l'appel a mysql soit fait !

elekaj34
13/09/2014, 17h58
Citation Envoyé par Nowwhat
Pourquoi poster le log de postfix sans mettre ton instal sasl en mode debug pour y voir plus clair ?
Dans la précipitation, j'ai oublié toutes mes excuses !
Voici la conf dans main.cf
Code:
# **********************************************
# *                    SASL                    *
# **********************************************
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = 
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes

# *********************************************
# *                    TLS                    *
# *********************************************
smtp_tls_CAfile = /etc/postfix/tls/cacert.pem
# smtp_tls_CAfile = /etc/postfix/tls/startssl.ca.pem
smtp_tls_security_level = may
smtp_tls_session_cache_database = btree:${data_directory}/smtp_tls_session_cache
smtpd_tls_security_level = may
smtpd_tls_auth_only = yes
smtpd_tls_key_file = /etc/postfix/tls/mail.key
smtpd_tls_cert_file = /etc/postfix/tls/mail.crt
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_tls_session_cache
tls_random_source = dev:/dev/urandom
le fichier /etc/postfix/sasl/smtpd.conf
Code:
pwcheck_method: saslauthd
mech_list: plain login
log_level: 5
Et le fichier /etc/pam.d/smtp
Code:
auth	required pam_mysql.so user=manager passwd=ieufupldlp host=127.0.0.1 db=postfix table=mailbox usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=manager passwd=ieufupldlp host=127.0.0.1 db=postfix table=mailbox usercolumn=email passwdcolumn=password crypt=1
et le /etc/default/saslauthd
Code:
#
# Settings for saslauthd daemon
# Please read /usr/share/doc/sasl2-bin/README.Debian for details.
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Description of this saslauthd instance. Recommended.
# (suggestion: SASL Authentication Daemon)
DESC="SASL Authentication Daemon"

# Short name of this saslauthd instance. Strongly recommended.
# (suggestion: saslauthd)
NAME="saslauthd"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent  -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam       -- use PAM
# rimap     -- use a remote IMAP server
# shadow    -- use the local shadow password file
# sasldb    -- use the local sasldb database file
# ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="pam"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

# Other options (default: -c -m /var/run/saslauthd)
# Note: You MUST specify the -m option or saslauthd won't run!
#
# WARNING: DO NOT SPECIFY THE -d OPTION.
# The -d option will cause saslauthd to run in the foreground instead of as
# a daemon. This will PREVENT YOUR SYSTEM FROM BOOTING PROPERLY. If you wish
# to run saslauthd in debug mode, please run it by hand to be safe.
#
# See /usr/share/doc/sasl2-bin/README.Debian for Debian-specific information.
# See the saslauthd man page and the output of 'saslauthd -h' for general
# information about these options.
#
# Example for chroot Postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
# Example for non-chroot Postfix users: "-c -m /var/run/saslauthd"
#
# To know if your Postfix is running chroot, check /etc/postfix/master.cf.
# If it has the line "smtp inet n - y - - smtpd" or "smtp inet n - - - - smtpd"
# then your Postfix is running in a chroot.
# If it has the line "smtp inet n - n - - smtpd" then your Postfix is NOT
# running in a chroot.
OPTIONS="-c -r -m /var/spool/postfix/var/run/saslauthd"
PS : Pour info, j'ai recopié les configs de l'ancien serveur vers le nouveau ... hors sur l'ancien, çà fonctionne au poil !
A part SASL, tout le reste fonctionne.

Pour la page google, merci mais j'ai déjà épluché pas mal de pages sans résultats

Nowwhat
13/09/2014, 16h34
Bonjour,

Plusieurs raisons possible.
Pourquoi poster le log de postfix sans mettre ton instal sasl en mode debug pour y voir plus clair ?

Pour toutes les vraies question posssibles, voici les réponses:
https://www.google.fr/search?q=warni..._fr&gws_rd=ssl

elekaj34
13/09/2014, 13h27
Bonjour,

Je suis en train de migrer d'un ancien serveur SP vers un SYS.
Lors de la migration du serveur mail, je bute sur un soucis avec SASL (le reste a priori fonctionne bien)

Le serveur : Debian Wheezy (up to date) + Postfix

Voici le message d'erreur :
Sep 13 14:12:33 altair postfix/smtpd[964]: connect from cro34-1-82-224-134-160.fbx.proxad.net[82.224.134.160]
Sep 13 14:12:33 altair postfix/smtpd[964]: Anonymous TLS connection established from cro34-1-82-224-134-160.fbx.proxad.net[82.224.134.160]: TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits)
Sep 13 14:12:35 altair postfix/smtpd[964]: warning: SASL authentication failure: Password verification failed
Sep 13 14:12:35 altair postfix/smtpd[964]: warning: cro34-1-82-224-134-160.fbx.proxad.net[82.224.134.160]: SASL PLAIN authentication failed: authentication failure
Sep 13 14:12:37 altair postfix/smtpd[964]: warning: cro34-1-82-224-134-160.fbx.proxad.net[82.224.134.160]: SASL LOGIN authentication failed: authentication failure
Sep 13 14:12:41 altair postfix/smtpd[964]: disconnect from cro34-1-82-224-134-160.fbx.proxad.net[82.224.134.160]
J'arrive pas a voir d'autre erreurs (dans d'autres logs)
Est ce possiblement un problème avec le certicat SSL ? qui devrait spécifique à chaque serveur (j'en doute) ?

d'autres pistes ?

Merci pour votre aide.