OVH Community, votre nouvel espace communautaire.

PTR : Error: Invalid IP address


Nowwhat
25/09/2014, 19h10
Citation Envoyé par bbr
Code:
        600    IN TXT    "v=spf1 a mx a:mon_domaine.com ip4:IP_FO ~all"
ce serait pas plutôt comme ça ?
Sous réserve que le (ton) serveur mail utilise le IPFO pour envoyer le mail, et pas un autre IP (l'IP du serveur par exemple).

bbr
25/09/2014, 17h12
Code:
        600    IN TXT    "v=spf1 a mx a:mon_domaine.com ip4:IP_FO ~all"
ce serait pas plutôt comme ça ?

CharlyGandhi
25/09/2014, 14h15
Bonjour à tous !!!

Me revoici encore et toujours dans tous mes petits test.
J'essaie d'avancer comme je peux ... voici ou j'en suis :

Via cmd :
- ping IPFO ok
- ping domaineclient.com ok

Via putty :
- host IPFO ok
IPFO(àl'envers).in-addr.arpa domain name pointer domaineclient.com

- host domaineclient.com :
domaineclient.com has adress IPFO
domaineclient.com mail is handled by 10 maildomaineclient.com

mail-tester me retourne toujours: FH_HELO_ALMOST_IP Helo is almost an IP addr

je viens de changer aussi la zone TXT pour mon SPF( qui me retournait toujours une erreur)
par v=spf1 mx ip4:IPFO mx:mail.domaineclient.com -all

J'attend la propagation maintenant ...

Ai-je bien fait pour le SPF ?

A bientôt pour de nouvelles aventures

CharlyGandhi
24/09/2014, 14h06
eth0 ---> IP normale --- Masque 255.255.255.0
eth0:1 ---> IPFO --- Masque 255.255.255.255


edit :
mon IPFO répond au ping donc je pense pas que le souci vienne de là.
Je pense que j'ai un souci de NS ... (l'instinct du débutant)
Je continue mes recherches

Au fait bbr : Merci de t'intéresser à mon problème ! c'est sympa de ta part

bbr
24/09/2014, 13h59
ifconfig donne quoi ?

CharlyGandhi
24/09/2014, 13h53
Re !

C'est du Cent OS oui !
Et oui j'ai suivi le guide OVH

C'est en forgeant qu'on devient forgeron J'essaie et j'apprends !

Je vais y arriver !!!

bbr
24/09/2014, 13h42
y a pas que plesk dans la vie (d'un serveur) ^^
as-tu configuré l'ip sur le serveur ? Serveur qui a quelle distribution avant plesk qui n'est qu'une surcocuhe graphique, c'est du Centos ?
As-tu fais ceci http://guides.ovh.com/AjouterAliasIp

franchement mettre un domaine sur une IP FO sans avoir aucune idée de comment ça fonctionne ce n'est pas génial, ton premier souci aurait pu être résolu sans t'engager dans cette voie qui t'est encore plus inconnue que le système des DNS.
Je n'ai aucune idée de comment Plesk gère tout ça et comme c'est un panel hyper propriétaire beaucoup ici ne te répondront que par rapport à des distributions standards d'où l'intérêt que tu ne fasses que des choses que tu maitrises ou au moins dont tu comprends le fonctionnement

CharlyGandhi
24/09/2014, 12h36
J'ai réussi à remettre le site en ligne.

@bbr voilà ce que j'ai fait :

Sous PLESK :
Serveur -> Adresses IP -> ajout de l'IPFO dédié
Espaces Web -> Création d'un espace dédié à domaineclient.com
Sites Web & Domaines -> domaineclient.com -> paramètre DNS (ça s'est fait en auto à l'ajout du domaine)
mais j'ai :
IPFO/24 - ptr - domaineclient.com
domaineclient.com - A - IPFO
domaineclient.com - MX(10) - maildomaineclient.com
domaineclient.com - TXT - v=spf1 +a +mx -all
mail.domaineclient.com - A - IPFO
domaineclient.com - NS - ns000000.ip-00-00-00.eu (qui correspond à mon serveur de départ)
domaineclient.com - NS - sdns2.ovh.net
et tous les autres ...

Sous manager soyoustart
Gérer les IPs -->
IPFO - reverse: mail.domaineclient.com


Je pense que mon souci vient de 2 choses : Le NS et SPF.
Par contre quoi changer ?

Peut être faut il attendre encore un peu de propagation...

bbr
24/09/2014, 11h04
petite question : comment as-tu configuré l'IP FO sur le serveur ?

CharlyGandhi
24/09/2014, 08h45
Bonjour à tous !

Aujourd'hui ... c'est la M**** !!!!
Mon nom de domaine ne pointe plus vers le site !

Moi qui pensait que ça s'améliorait

Nowwhat
23/09/2014, 21h19
Hummm.

Regarde:

root@ns311465:/var/log/apache2# host louiseyyy.com
louisemoi.com has address 46.xx.62.119
louisemoi.com mail is handled by 10 mail.louiseyyy.com.

root@ns311465:/var/log/apache2# host mail.louiseyyy.com
mail.louisemoi.com has address 46.xx.62.119

root@ns311465:/var/log/apache2# host 46.xx.62.119
119.62.xx.46.in-addr.arpa domain name pointer mail.louiseyyy.com.

Pour cet IP 46.xx.62.119, le reverse est bien correctement mis sur mail.louiseyyy.com.

Ton serveur mail est sensé utiliser l'IP(FO !) 46.xx.62.119, certainement pas "ns204829.ip-94-23-aa.eu (ns204829.ip-94-23-aa.eu [94.23.aa.222]" comme IP de transmission.

Il faut donc informer postfix qu'il faut qu'il utilise 46.xx.62.119 comme IP-de-sortie. Pas "94.23.aa.222".
Ce que je fait avec toutes mes IPFO = j'en prend autant des IPFO que des domaines sur mon serveur, puis j'informe postfix qu'il faut qu'il utilise
IPFO1 = domaine1.tld
IPFO2 = domaine2.tld
etc.

Va voir ici pour comprendre : https://admin-serv.net/blog/624/post...-de-lemetteur/

PLan B : mentionne les IP "94.23.aa.222" et "46.xx.62.119" dans ton SPF.

Va voir aussi ici:
http://www.dnsinspect.com et saisi ton nom de domaine, louiseyyy.com
(et tant que tu y est: URGENT => REPARE CECI:
WARNING: The following name servers announces themselves as open DNS servers:
udp4:94.23.aa.222
)

Il reste d’autres petit truc à 'réparer' coté DNS .....

N'arrête pas avant que t'as un un gros A de partout: exemple: un domaine à moi : http://www.dnsinspect.com/test-domaine.fr

CharlyGandhi
23/09/2014, 17h21
Bon ... je fais encore des test pour changer !!!

quand je fais un :
dig mail.domaineclient.com +short
Je tombe sur l'IPFO


Je test un :
host domaineclient.com
Je tombe sur l'IPFO


Je test un ( ou x correspond à l'IPFO ) :
host xx.xxx.xx.xxx
Je tombe sur IPFO à l'envers (si IPFO normal est 1.2.3.4) soit
4.3.2.1.in-addr.arpa domain name pointer mail.domaineclient.com


En espérant que ces retours puissent aider quelqu'un à m'aider
tiens elle est cool cette phrase !

CharlyGandhi
23/09/2014, 13h36
Sur le manager soyoustart : le reverse n'accepte pas loxxx.com
c'est donc mail.loxx.com

Sur Plesk:
je ne sais pas comment le mettre (je pensait que c'était le PTR)


Pour le SPF j'ai mis la valeur que me conseillait Spamassassin.

Pour le DKIM : C'est uen autre histoire ... je ne sais pas comment faire ! je voulais en prio gérer ce qui me faisait persre le plus de point !

bbr
23/09/2014, 13h25
le reverse de l'ip 46.xxx.xxx.xxx c'est bien le nom de domaine loxxx.com ?
le spf v=spf1 a mx a:ns204xxx.ip-xx-xx-xx.eu -all" devrait plutôt être
v=spf1 a mx a:loxxx.com ip4:46.xxx.xxx.xxx -all"
tu dois aussi générer un DKIM

CharlyGandhi
23/09/2014, 12h59
Bonjour bbr,

Voici les zones DNS de mon client

IPFO/24 ---> PTR ---> nomdedomaineclient.com
mail.nomdedomaineclient.com ---> A ---> IPFO
nomdedomaineclient.com ---> A ---> IPFO
nomdedomaineclient.com ---> NS ---> monns.ip-blabla.eu
nomdedomaineclient.com ---> NS ---> sdns2.ovh.net
...

le mail-tester :
web-Ip2Dwp@mail-tester.com


J'ai forcement du faire un truc qui n'allait pas


Edit:
J'ai fait le dig que me parlait Nowwhat et je tombe bien sur mon IPFO

bbr
23/09/2014, 12h49
et si tu nous donnais le lien du résultat de mail-tester, ce serait plus simple, ainsi que ta zone dns
dans le manager, tu dois mettre le nom de domaine.tld comme reverse pour l'ip fo, rien rajouter d'autre pas de mail.domaine.tld
rien que ça, cela devrait aider
ensuite il faut que la boite qui envoie le mail soit une boite @mondomaine.tld

edit : je ne connais pas plesk non plus

CharlyGandhi
23/09/2014, 12h11
Bon !!! me revoilà !

Je viens de mettre en place une IPFO que j'ai commandé chez via le manager soyoustart !

Après installation, j'ai mis en reverse : MAIL.domainedemonclient.com sur le manger soyoustart
Ensuite depuis Plesk, j'ai ajouter une IP (serveur IP)
Puis j'ai copier cette IP et dans le domaineclient.com rubrique paramètre DNS j'ai remplacer l'IP de base par la nouvelle IPFO.

quand je fait un whatmydns.net

type A = nouvelle IPFO OK
PTR = toujours Error: Invalid IP address

Ahhhhhhhhh

CharlyGandhi
23/09/2014, 10h51
Un immerce merci Nowwhat !
Je pensait être seul sur cette discution

Si je comprend bien ce que tu me dis je dois créer une IPFO (Ou et comment ? ) que j'attitre au site de mon client (parmètre DNS du site de mon client ? ) !
Ensuite je me connect au serveur via un putty par exemple ? et je check ta ligne dig MAIL.domainedemonclient.com +short qui me retournera l'IP à mettre dans le manager soyoustart ?


C'est pas très clair pour moi tout ça !

Nowwhat
23/09/2014, 10h37
Bonjour,
Citation Envoyé par CharlyGandhi
.... une petite chose qui m'enlève pas mal de point: FH_HELO_ALMOST_IP
Tant que tu garde "ns311465.ip-188-165-201.eu" comme reverse, t'auras des types comme spamassassin qui mentionne : "FH_HELO_ALMOST_IP".

Le bon plan: t'occupe pas de l'IP 'natif' de ton serveur, l'IP avec le reverse "ns311465.ip-188-165-201.eu".
Il existe pour toi et TOI seulement - ne le communique jamais à un tiers.
Pour 2€40 t'auras un IPFO.
C'est lui que tu utilisera pour ton site, mail, etc etc.

Mais bon, ce n'est qu'une habitude.

Pour modifier ton reverse, il faut que le reverse est reconnu par ton serveur DNS.
Par exemple,
dig MAIL.domainedemonclient.com +short
doit te donner l'IP qui va avec MAIL.domainedemonclient.com comme réponse.
Tant que ce n'est pas fait, le Manager n'accepte pas ce nouveau reverse.
Le même test est exécuté par le manager, là ou tu change ton reverse.

Edit: la fouille: désolé, je ne sais pas comment utiliser Plesk.
Puis désolé, ne j'ai pas pu donner plus de détails - t'en donne aucun non plus

CharlyGandhi
23/09/2014, 10h32
Je continue de fouiller...

Je me demande s'il ne faut pas créer une adresse IP pour le site de mon client.

Question 1:
Dans Plesk Serveur IP. Ajouter une adresse IP.
Disons que l'IP de mon serveur est XX.XX.XX.XXX
Quelle IP dois-je ajouter ?

Question 2 :
Je n'arrive pas à ajouter une IP du type (IPv4) qui s'apparante avec l'IP de mon serveur un truc du style XX.XX.XX.XXX/64.
Par contre l'IPv6 fonctionne avec un ruc du style XXX:XXXX:X:XXX::2 au lieu de XXX:XXXX:X:XXX::1
Pourriez vous m'éclairer sur le but de cette manip ?

Question 3 :
Les 2 IP que j'ai actuellemnt sou Plesk (v4 et v6) sont associées à mon domaine principal.
Mais quand j'en crée une nouvelle, dans le choix "site par défaut" je n'ai le choix que de "Aucun".
Comment ça marche

Question 4 :
Dans l'administration Soyoustart j'ai vu que je pouvais mettre une reverse mais l'IP créer n'apparait pas
Pourtant il me met "Il reste 16 suffixes disponibles pour ce serveur."
Comment la faire apparaitre et quoi mettre en reverse ?

Question 5:
A votre avis suis-je sur la bonne voie ...

To be continued ...

CharlyGandhi
23/09/2014, 09h08
Bon ... ça n'a rien changé

Quelqu'un à déjà eu ce souci ?

CharlyGandhi
22/09/2014, 16h42
Et bien pas grand chose n'avance !

Après quelques heure d'attente j'ai toujours les mêmes messages "Error: Invalid IP address" et "FH_HELO_ALMOST_IP"

Quelqu'un a t il une solution ?

J'attend demain (au cas ou la nuit me propage tout ça, même si j'en doute ) avant de changer le PTR pour ce qu'il était par défaut.

Bonne soirée

CharlyGandhi
22/09/2014, 12h15
Bon ... je viens de faire un changement pour tester ce que j'ai dis dans le #2
J'attend la propagation pour faire les tests et vérifier si c'est vrai ...

Je reviens vers vous dès que j'en sais plus !

CharlyGandhi
22/09/2014, 12h04
J'ai quelques petit souci à comprendre certaines choses

Récapitulons,
le PTR resoud une IP vers un nom de domaine.
J'ai un souci de PTR pour l'envoi des mails

Question : Quel est le rapprochement entre PTR et les mails ?

Réflexion : si le PTR a à voir avec les mails alors ne devrait il pas avoir une forme de ce type :
IPDEMONSERVEUR / 24 --> PTR --> MAIL.domainedemonclient.com
et du coup ressembler à mon MX (10)

Là est la question que je me pose

CharlyGandhi
22/09/2014, 11h35
Bonjour à tous,

Je viens vers vous car je galère !!!

J'essaie d'envoyer un emailing pour un client.
Et après plusieurs test via mail-tester.com je voudrais corriger une petite chose qui m'enlève pas mal de point: FH_HELO_ALMOST_IP

Après moult forum / discussions / recherche je vois que c'est le reverse de mon serveur qui à un souci.
Les solutions sont de gérer correctement un enregistrement PTR.


son nom de domaine est enregistré sous OVH et j'ai changer les 2 NS pour pointer vers mon dédié.
Mon dédié est administré via plesk 11.5

Mon dédié gère le PTR en fonction de chaque domaine du type : / 24 PTR .
Sur son domaine (rubrique paramètre DNS) j'ai bien:
IPDEMONSERVEUR / 24 PTR domainedemonclient.com

Cependant après test (via whatsmydns.net) nomdedomaineclient.com, le PTR me retourne Error: Invalid IP address

Que puis-je faire pour éviter ce genre de problème ?