OVH Community, votre nouvel espace communautaire.

Géolocalisation domaine


toonetcreation
07/12/2014, 10h52
non en effet

ce que j'ai fais c'est que j'ai remis les lignes ci-dessous dans le fichier /etc/network/interfaces

post-up /sbin/ifconfig eth0:1 MA_NOUVELLE_IP netmask 255.255.255.255 broadcast MA_NOUVELLE_IP
post-down /sbin/ifconfig eth0:1 down


tout fonctionne malgré le fameux message..au pire j'appellerais le support SYS pour leur demander leur avis.

Abazada
07/12/2014, 09h11
Oui. J'aurais pû le préciser: malgré ces messages tout fonctionne comme il faut côté réseau/IpFo

Le problème disparaitra au prochain reboot, mais il n'est nullement nécessaire de rebooter juste pour ça.

toonetcreation
07/12/2014, 08h44
donc au pire si je redémarre le serveur je ne devrais plus rien voir?
car la, malgré le message indiqué, après avoir ajouté la nouvelle IP, le domaine fonctionne bien...donc c'est que ça m'a l'air bon j'ai l'impression :-/

Abazada
07/12/2014, 03h42
Bonjour,
Je ne suis pas du tout spécialiste des conf réseaux mais j'ai déjà constaté ce que tu décries là,
comme si le hardware (la carte réseaux) mémorisait les eth:0, :1, :2,... une fois configurés.
Un reboot (soft) et tout rentre dans l'ordre

toonetcreation
06/12/2014, 18h53
ok par contre j'ai fais un test:

- j'ai supprimé les lignes suivantes du fichier /etc/network/interfaces

post-up /sbin/ifconfig eth0:1 MA_NOUVELLE_IP netmask 255.255.255.255 broadcast MA_NOUVELLE_IP
post-down /sbin/ifconfig eth0:1 down


- j'ai relancé l'interface réseau avec /etc/init.d/networking restart

- je fais un ifconfig et j'obtiens ceci (voir en rouge ci-dessous). c'est normal? même l'ayant supprimé du fichier ?
c'est comme si même ayant remis le fichier d'origine cela gardait quand même les modifications faites avant :-/

eth0 XXXXXXXXXX

eth0:1 Link encap:Ethernet HWaddr 70:54:d2:19:9a:d7
inet adr:MA_NOUVELLE_IP Bcast:MA_NOUVELLE_IP Masque:255.255.255.255
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interruption:20 Mémoire:fe500000-fe520000


lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:77270 errors:0 dropped:0 overruns:0 frame:0
TX packets:77270 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:20027511 (19.0 MiB) TX bytes:20027511 (19.0 MiB)

Abazada
06/12/2014, 10h05
Normal? je ne sais pas, mais j'ai les mêmes
Il y a 2 messages en fait:
- le "deprecated" sur le "restart" , mais par quoi le remplacer pour que ça reste simple ?
- le RTNETLINK qui est une "notice" mais que je ne sais pas corriger en Debian 7.7

toonetcreation
06/12/2014, 08h08
j'ai rajouté ces lignes dans /etc/network/interfaces

post-up /sbin/ifconfig eth0:1 MA_NOUVELLE_IP netmask 255.255.255.255 broadcast MA_NOUVELLE_IP
post-down /sbin/ifconfig eth0:1 down


après je fais un /etc/init.d/networking restart

est-ce normal que j'ai ce message ?

[....] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfac[warn. (warning).
[....] Reconfiguring network interfaces...RTNETLINK answers: No such process
done.

toonetcreation
06/12/2014, 07h53
il s'agit d'une debian 7.5
j'ai ajouté l'IP dans le champ A de la zone DNS du domaine.
je vais regarder le doc.
merci

Abazada
06/12/2014, 02h09
Si.
Il faut informer ton serveur qu'il doit gérer cette nouvelle IP: http://guides.ovh.net/AjouterAliasIp

Suivant ta distribution et configuration, il se peut que tu aies à indiquer/configure
cetteIpFo dans certains fichiers de conf aussi

toonetcreation
05/12/2014, 14h47
Ok c'est bon j'ai commandé mon IP.
par contre à part mettre à jour la zone DNS du domaine, y'a rien de plus à faire?
puisque la nouvelle IP est routé vers l'IP du serveur dédié?

toonetcreation
01/12/2014, 09h07
ok merci pour les infos.
oui je suis d'accord avec toi, c'est un client qui insiste et me demande ça.
donc au pire je vais lui mettre et il sera content

Abazada
01/12/2014, 08h52
Citation Envoyé par toonetcreation
ok je vois.
rien de plus à faire comme manip?
je veux dire coté serveur ?

c'est payant ou on l'a par défaut l'IP supp?
Sur Soyoustart les IpFo sont gratuites mensuellement, juste un prix d' "achat" de 2 €.

La manip d'install d'une IpFo : http://guides.ovh.net/AjouterAliasIp

L'influence d'un IpFo geolocalisée.... ça se discute fortement

toonetcreation
01/12/2014, 08h18
ok je vois.
rien de plus à faire comme manip?
je veux dire coté serveur ?

c'est payant ou on l'a par défaut l'IP supp?

Abazada
28/11/2014, 15h59
Citation Envoyé par toonetcreation
Je souhaiterais géolocaliser à l'étranger un de ces noms de domaines.
Quelqu'un sait-il comment faire par hasard ?
La solution habituelle est d'installer sur ton serveur un IP supplémentaire (IpFo)
appartenant au pays que tu vises, et de l'utiliser en A pour le domaine en question.

toonetcreation
27/11/2014, 15h17
Bonjour,

J'ai un dédié chez SoYouStart et je gère mes noms de domaines chez OVH via le manager.
Je souhaiterais géolocaliser à l'étranger un de ces noms de domaines.

Quelqu'un sait-il comment faire par hasard ?

J'ai déjà contacté OVH et voici leur réponse :

Cette option est uniquement possible depuis votre espace client lorsque vous disposez d'un hébergement mutualisé chez OVH. Votre site en question pointe par contre sur un serveur d'hébergement dédié SoYouStart .

Je vous conseille donc de vous rapprocher du support SoYouStart pour vérifier si des solutions adaptées à votre offre existe :

http://www.soyoustart.com/fr/support/


Merci
Laurent